#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)^[a-z0-9\.-_]+[@][a-z0-9-_]+[\.][a-z0-9\.]{2,5}$"
Local $sString = "michael.kindle@gmail.co.uk"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")