re = /^[a-z0-9\.-_]+[@][a-z0-9-_]+[\.][a-z0-9\.]{2,5}$/i
str = 'michael.kindle@gmail.co.uk'
# Print the match result
str.match(re) do |match|
puts match.to_s
end