$re = '/^([`~!@#$%^&*()_\-+={}[\]\\\\\|:;"\'<>,\.\?\/a-zA-Z0-9]{6,40})$/';
$str = '~!aaaaa()
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);