re = /^([`~!@#$%^&*()_\-+={}[\]\\\|:;"'<>,\.\?\/a-zA-Z0-9]{6,40})$/
str = '~!aaaaa()
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end