using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+|\d+[-]\d+)(?=\s?)(?![-])";
string input = @"NFPA 101 7.9.3
NFPA 101 7-9.3";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}