$re = '/(\w+|\d+[-]\d+)(?=\s?)(?![-])/';
$str = 'NFPA 101 7.9.3
NFPA 101 7-9.3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);