$re = '/\'(?:text|created_at)\':\s+u\'\K[^\']*/m';
$str = 'string <- "{\'text\': u\'@RobertTekieli @Czerniakowianka @1234Mania mysle, ze nie weszlabym do zadnego wiezienia bez straznikow\', \'created_at\': u\'Tue May 20 08:16:55 +0000 2014\'}"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);