re = /'(?:text|created_at)':\s+u'\K[^']*/m
str = 'string <- "{\'text\': u\'@RobertTekieli @Czerniakowianka @1234Mania mysle, ze nie weszlabym do zadnego wiezienia bez straznikow\', \'created_at\': u\'Tue May 20 08:16:55 +0000 2014\'}"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end