#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https?:\/\/flyheight.com\/videos\/[a-z0-9]{6}$"
Local $sString = "https://flyheight.com/videos/ybb347" & @CRLF & _
"" & @CRLF & _
"https://flyheight.com/videos/yb24os" & @CRLF & _
"" & @CRLF & _
"https://flyheight.com/public/images/videos/793f77362f321e62c32659c3ab00952d.png" & @CRLF & _
"" & @CRLF & _
"https://flyheight.com/videos/5o6t98/#disqus_thread"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")