import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https?:\\/\\/flyheight.com\\/videos\\/[a-z0-9]{6}$";
final String string = "https://flyheight.com/videos/ybb347\n\n"
+ "https://flyheight.com/videos/yb24os\n\n"
+ "https://flyheight.com/public/images/videos/793f77362f321e62c32659c3ab00952d.png\n\n"
+ "https://flyheight.com/videos/5o6t98/#disqus_thread";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}