import re
regex = re.compile(r"insert[\s]+into[\s]+\([\s]*(?<columns>.*?)[\s]*\)[\s]+values[\s]+\((?<values>.*?)[\s]*\);", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("insert into ( a, b, c ) values ( \" insert into values (1,2,3)\",1,2.3,\"a,b\" );\n\n"
"insert into (ee,bb,cc) values (aa,234,\"asj\",2.3);")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")