import Foundation
let pattern = #"insert[\s]+into[\s]+\([\s]*(?<columns>.*?)[\s]*\)[\s]+values[\s]+\((?<values>.*?)[\s]*\);"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
insert into ( a, b, c ) values ( " insert into values (1,2,3)",1,2.3,"a,b" );
insert into (ee,bb,cc) values (aa,234,"asj",2.3);
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)