$re = '/^(.*?)(?=\?|$)/m';
$str = '#test
#test?params=something';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;