re = /^(.*?)(?=\?|$)/m
str = '#test
#test?params=something'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result