#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^[\w+-.%]+@[\w-.]+\.[A-Za-z]{2,4}(?:,[\w+-.%]+@[\w-.]+\.[A-Za-z]{2,4})*$"
Local $sString = "asdas@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")