// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^[\w+-.%]+@[\w-.]+\.[A-Za-z]{2,4}(?:,[\w+-.%]+@[\w-.]+\.[A-Za-z]{2,4})*$").unwrap();
let string = "asdas@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com,asdasd@gmail.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}