import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:[^\"\\n]*\"[^\"\\n]*\")*[^\"\\n]*)\"[^\"\\n]*\\n[^\"\\n]*\"(\\n|)";
final String string = "\"This is a quote\"\n"
+ "This is an end \"partial-\n"
+ "quote\" Here is more text.\n"
+ "This is an end \"partial-\n"
+ "quote w/o more text\"\n"
+ "This is an \"embedded\" quote";
final String subst = "$1\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}