import re
regex = re.compile(r"^((?:[^\"\n]*\"[^\"\n]*\")*[^\"\n]*)\"[^\"\n]*\n[^\"\n]*\"(\n|)", flags=re.MULTILINE)
test_str = ("\"This is a quote\"\n"
"This is an end \"partial-\n"
"quote\" Here is more text.\n"
"This is an end \"partial-\n"
"quote w/o more text\"\n"
"This is an \"embedded\" quote")
subst = "$1\\n"
result = regex.sub(subst, test_str)
if result:
print(result)