use strict;
my $str = 'G06242 90 4 ATLASSIAN CORP PLC CALL
G06242 95 4 ATLASSIAN CORP PLC PUT
G0692U 10 9 * AXIS CAPITAL HOLDINGS LTD SHS
G0692U 90 9 AXIS CAPITAL HOLDINGS LTD CALL
G0692U 95 9 AXIS CAPITAL HOLDINGS LTD PUT
G07021 12 7 * CHC GROUP LTD SHS NEW DELETED
G07021 90 7 CHC GROUP LTD CALL DELETED
G07021 95 7 CHC GROUP LTD PUT DELETED
G0750C 10 8 * AXALTA COATING SYS LTD COM
G0750C 90 8 AXALTA COATING SYS LTD CALL
G0750C 95 8 AXALTA COATING SYS LTD PUT
G0750W 10 4 * AXOVANT SCIENCES LTD COM
G0750W 90 4 AXOVANT SCIENCES LTD CALL
G0750W 95 4 AXOVANT SCIENCES LTD PUT
G10082 14 0 * ENERGY XXI LTD USD UNRS SHS
G10082 90 0 ENERGY XXI LTD CALL
G10082 95 0 ENERGY XXI LTD PUT
G1151C 10 1 * ACCENTURE PLC IRELAND SHS CLASS A
G1151C 90 1 ACCENTURE PLC IRELAND CALL
G1151C 95 1 ACCENTURE PLC IRELAND PUT
G1154H 10 7 * BELMOND LTD CL A
G1154H 90 7 BELMOND LTD CALL
G1154H 95 7 BELMOND LTD PUT
G1190F 10 7 BLUE CAP REINS HLDGS LTD COM
G14838 10 9 MIMECAST LTD ORD SHS
G16249 10 7 * BROOKFIELD PPTY PARTNERS L P UNIT LTD PARTN
G16249 90 7 BROOKFIELD PPTY PARTNERS L P CALL
G16249 95 7 BROOKFIELD PPTY PARTNERS L P PUT
G16252 10 1 * BROOKFIELD INFRAST PARTNERS LP INT UNIT
G16252 90 1 BROOKFIELD INFRAST PARTNERS CALL
G16252 95 1 BROOKFIELD INFRAST PARTNERS PUT
G16258 10 8 * BROOKFIELD RENEWABLE ENRGY P PARTNERSHIP UNIT
G16258 90 8 BROOKFIELD RENEWABLE ENRGY P CALL
G16258 95 8 BROOKFIELD RENEWABLE ENRGY P PUT
CUSIP NO ISSUER NAME ISSUER DESCRIPTION STATUS
8:54 IVM001
Run Date: 4/5/2016 ** List of Section 13F Securities ** Page 4
Run Time: Year: 2016 Qtr: 1
G16962 10 5 * BUNGE LIMITED COM
G16962 90 5 BUNGE LIMITED CALL
G16962 95 5 BUNGE LIMITED PUT
G20045 20 2 * CENTRAL EUROPEAN MEDIA ENTRP CL A NEW
G20045 90 2 CENTRAL EUROPEAN MEDIA ENTRP CALL
G20045 95 2 CENTRAL EUROPEAN MEDIA ENTRP PUT
G2029P 10 0 C B PHARMA ACQUISITION CORP UNIT 12/17/2021
G2029P 11 8 C B PHARMA ACQUISITION CORP *W EXP 12/17/202
G2029P 12 6 C B PHARMA ACQUISITION CORP SHS
G2029P 13 4 C B PHARMA ACQUISITION CORP RIGHT 06/17/2016
G21082 10 5 * CHINA YUCHAI INTL LTD COM
G21082 90 5 CHINA YUCHAI INTL LTD CALL
G21082 95 5 CHINA YUCHAI INTL LTD PUT
G2110R 11 4 * CHIPMOS TECH BERMUDA LTD SHS
G2110R 90 4 CHIPMOS TECH BERMUDA LTD CALL
G2110R 95 4 CHIPMOS TECH BERMUDA LTD PUT
G2110U 10 9 CHINA NATURAL RESOURCES INC COM
G21107 10 0 CHINA CORD BLOOD CORP SHS
G2113X 10 0 CHINA CERAMICS CO LTD SHS
G21174 10 0 * CHINA INFORMATION TECHNOLOGY COM
G21174 90 0 CHINA INFORMATION TECHNOLOGY CALL
G21174 95 0 CHINA INFORMATION TECHNOLOGY PUT
G2118P 10 2 CHINA CUST RELATIONS CNTR IN COM
G23773 10 7 * CONSOLIDATED WATER CO INC ORD
G23773 90 7 CONSOLIDATED WATER CO INC CALL
G23773 95 7 CONSOLIDATED WATER CO INC PUT
G2519Y 10 8 * CREDICORP LTD COM
G2519Y 90 8 CREDICORP LTD CALL
G2519Y 95 8 CREDICORP LTD PUT
G25343 10 7 * COSAN LTD SHS A
G25343 90 7 COSAN LTD CALL
G25343 95 7 COSAN LTD PUT
G25861 AA 6 CTRIP COM INTERNATIONAL LTD DEBT 0.500% 9/1
G25861 AC 2 CTRIP COM INTERNATIONAL LTD DEBT 1.000% 7/0
CUSIP NO ISSUER NAME ISSUER DESCRIPTION STATUS
8:54 IVM001
Run Date: 4/5/2016 ** List of Section 13F Securities ** Page 5
Run Time: Year: 2016 Qtr: 1
G25861 AD 0 CTRIP COM INTERNATIONAL LTD DEBT 1.990% 7/0
G2615J 10 4 DT ASIA INVTS LTD SHS
G2615J 11 2 DT ASIA INVTS LTD RIGHT 03/30/2016
G2615J 12 0 DT ASIA INVTS LTD UNIT 03/29/2021T
G2615J 13 8 DT ASIA INVTS LTD *W EXP 03/29/202
G27010 10 0 DEHAIER MEDICAL SYSTEMS LIMI SHS
G27823 10 6 * DELPHI AUTOMOTIVE PLC SHS
G27823 90 6 DELPHI AUTOMOTIVE PLC CALL
G27823 95 6 DELPHI AUTOMOTIVE PLC PUT
G28195 10 8 DOUBLE EAGLE ACQUISITION COR UNIT 99/99/9999
G28195 11 6 DOUBLE EAGLE ACQUISITION COR *W EXP 09/16/202
G28195 12 4 DOUBLE EAGLE ACQUISITION COR COM
G29183 10 3 * EATON CORP PLC SHS
G29183 90 3 EATON CORP PLC CALL
G29183 95 3 EATON CORP PLC PUT
G2920Y 10 1 E COMPASS ACQUISITION CORP ORD SHS
G2920Y 11 9 E COMPASS ACQUISITION CORP RIGHT 02/18/2017
G2920Y 20 0 E COMPASS ACQUISITION CORP UNIT 99/99/9999
G29438 10 1 EFUTURE HOLDING INC SHS
G2952T AA 1 E HOUSE CHINA HOLDINGS LIMIT DEBT 2.750%12/1
G30397 10 6 * ENDURANCE SPECIALTY HLDGS LT SHS
G30397 90 6 ENDURANCE SPECIALTY HLDGS LT CALL
G30397 95 6 ENDURANCE SPECIALTY HLDGS LT PUT
G30401 10 6 * ENDO INTL PLC SHS
G30401 90 6 ENDO INTL PLC CALL
G30401 95 6 ENDO INTL PLC PUT
G3075P 10 1 ENSTAR GROUP LIMITED SHS
G3105C 10 4 ELECTRUM SPL ACQUISITION COR SHS
G3105C 11 2 ELECTRUM SPL ACQUISITION COR *W EXP 99/99/999
G3105C 12 0 ELECTRUM SPL ACQUISITION COR UNIT 99/99/9999
G3156P 10 3 * ASA GOLD AND PRECIOUS MTLS L SHS
G3156P 90 3 ASA GOLD AND PRECIOUS MTLS L CALL
G3156P 95 3 ASA GOLD AND PRECIOUS MTLS L PUT
G3157S 10 6 * ENSCO PLC SHS CLASS A
CUSIP NO ISSUER NAME ISSUER DESCRIPTION STATUS
8:54 IVM001
Run Date: 4/5/2016 ** List of Section 13F Securities ** Page 6
Run Time: Year: 2016 Qtr: 1
G3157S 90 6 ENSCO PLC CALL
G3157S 95 6 ENSCO PLC PUT
G3163G 10 4 CHINA METRO-RURAL HLDGS LTD SHS
G3164Q 10 1 * C&J ENERGY SVCS LTD SHS
G3164Q 90 1 C&J ENERGY SVCS LTD CALL
G3164Q 95 1 C&J ENERGY SVCS LTD PUT
G3198U 10 2 * ESSENT GROUP LTD COM
G3198U 90 2 ESSENT GROUP LTD CALL
G3198U 95 2 ESSENT GROUP LTD PUT
G32030 12 7 EURO TECH HOLDINGS CO LTD SHS NEW
G3223R 10 8 * EVEREST RE GROUP LTD COM
G3223R 90 8 EVEREST RE GROUP LTD CALL
G3223R 95 8 EVEREST RE GROUP LTD PUT
G3323L 10 0 * FABRINET SHS
G3323L 90 0 FABRINET CALL
G3323L 95 0 FABRINET PUT
G33856 10 8 * FERROGLOBE PLC SHS
G33856 90 8 FERROGLOBE PLC CALL
G33856 95 8 FERROGLOBE PLC PUT
G35569 10 5 * FLEETMATICS GROUP PLC COM
G35569 90 5 FLEETMATICS GROUP PLC CALL
G35569 95 5 FLEETMATICS GROUP PLC PUT
G36738 10 5 * FRESH DEL MONTE PRODUCE INC ORD
G36738 90 5 FRESH DEL MONTE PRODUCE INC CALL
G36738 95 5 FRESH DEL MONTE PRODUCE INC PUT
G3682E 12 7 * FRONTLINE LTD SHS DELETED
G3682E 90 7 FRONTLINE LTD CALL DELETED
G3682E 95 7 FRONTLINE LTD PUT DELETED
G3682E 19 2 * FRONTLINE LTD SHS NEW ADDED
G3682E 90 2 FRONTLINE LTD CALL ADDED
G3682E 95 2 FRONTLINE LTD PUT ADDED
G3704F 10 2 FUWEI FILMS HLDGS CO LTD SHS
G3729B 10 2 FULING GLOBAL INC SHS
G37585 10 9 * GASLOG LTD SHS
CUSIP NO ISSUER NAME ISSUER DESCRIPTION STATUS
8:54 IVM001
Run Date: 4/5/2016 ** List of Section 13F Securities ** Page 7
Run Time: Year: 2016 Qtr: 1
G37585 90 9 GASLOG LTD CALL
G37585 95 9 GASLOG LTD PUT
G3788M 11 4 * EROS INTL PLC SHS NEW
G3788M 90 4 EROS INTL PLC CALL
G3788M 95 4 EROS INTL PLC PUT
G38327 10 5 GEOPARK LTD USD SHS
G3922B 10 7 * GENPACT LIMITED SHS
G3922B 90 7 GENPACT LIMITED CALL
G3922B 95 7 GENPACT LIMITED PUT
G39300 10 1 GLOBAL SOURCES LTD ORD
G39319 10 1 * GLOBAL INDEMNITY PLC SHS
G39319 90 1 GLOBAL INDEMNITY PLC CALL
G39319 95 1 GLOBAL INDEMNITY PLC PUT
G39320 11 7 GLOBAL TECH ADVANCED INNOVAT SHS NEW DELETED
G39637 10 6 * GOLDEN OCEAN GROUP LTD SHS
G39637 90 6 GOLDEN OCEAN GROUP LTD CALL
G39637 95 6 GOLDEN OCEAN GROUP LTD PUT
G40357 10 8 GP INVTS ACQUISITION COR *W EXP 05/19/202
G40357 11 6 GP INVTS ACQUISITION COR UNIT 99/99/9999
G40357 12 4 GP INVTS ACQUISITION COR SHS
G4095J 10 9 * GREENLIGHT CAPITAL RE LTD CLASS A
G4095J 90 9 GREENLIGHT CAPITAL RE LTD CALL
G4095J 95 9 GREENLIGHT CAPITAL RE LTD PUT
G4388N 10 6 * HELEN OF TROY CORP LTD COM
G4388N 90 6 HELEN OF TROY CORP LTD CALL
G4388N 95 6 HELEN OF TROY CORP LTD PUT
G4412G 10 1 * HERBALIFE LTD COM USD SHS
G4412G 90 1 HERBALIFE LTD CALL
G4412G 95 1 HERBALIFE LTD PUT
G4481U 10 6 HIGHWAY HLDGS LTD ORD
G45667 10 5 * HOLLYSYS AUTOMATION TECHNOLO SHS
G45667 90 5 HOLLYSYS AUTOMATION TECHNOLO CALL
G45667 95 5 HOLLYSYS AUTOMATION TECHNOLO PUT
G4617B 10 5 * HORIZON PHARMA PLC SHS
CUSIP NO ISSUER NAME ISSUER DESCRIPTION STATUS
8:54 IVM001
Run Date: 4/5/2016 ** List of Section 13F Securities ** Page 8
Run Time: Year: 2016 Qtr: 1
G4617B 90 5 HORIZON PHARMA PLC CALL
G4617B 95 5 HORIZON PHARMA PLC PUT
G4705A 10 0 * ICON PLC SHS
G4705A 90 0 ICON PLC CALL
G4705A 95 0 ICON PLC PUT
G47204 10 5 * IAO KUN GROUP HLDG CO LTD ORD USD SHS
G47204 90 5 IAO KUN GROUP HLDG CO LTD CALL
G47204 95 5 IAO KUN GROUP HLDG CO LTD PUT
G47791 10 1 * INGERSOLL-RAND PLC SHS
G47791 90 1 INGERSOLL-RAND PLC CALL
G47791 95 1 INGERSOLL-RAND PLC PUT
G4783X 10 5 INNOCOLL HLDGS PLC SHS ADDED
G4863A 10 8 * INTERNATIONAL GAME TECHNOLOG SHS USD
G4863A 90 8 INTERNATIONAL GAME TECHNOLOG CALL
G4863A 95 8 INTERNATIONAL GAME TECHNOLOG PUT
G48833 10 0 * WEATHERFORD INTL PLC ORD SHS
G48833 90 0 WEATHERFORD INTL PLC CALL
G48833 95 0 WEATHERFORD INTL PLC PUT
G491BT 10 8 * INVESCO LTD SHS
G491BT 90 8 INVESCO LTD CALL
G491BT 95 8 INVESCO LTD PUT
G5005R 10 7 * JAMES RIV GROUP LTD COM
G5005R 90 7 JAMES RIV GROUP LTD CALL
G5005R 95 7 JAMES RIV GROUP LTD PUT
G50871 10 5 * JAZZ PHARMACEUTICALS PLC SHS USD
G50871 90 5 JAZZ PHARMACEUTICALS PLC CALL
G50871 95 5 JAZZ PHARMACEUTICALS PLC PUT
G5138L 10 0 * JINPAN INTL LTD ORD
G5138L 90 0 JINPAN INTL LTD CALL
G5138L 95 0 JINPAN INTL LTD PUT
G51385 AA 3 JINKOSOLAR HLDG CO LTD DEBT 4.000% 2/0
G52237 10 7 AVOLON HLDGS LTD COM DELETED
G5258J 10 9 * KING DIGITAL ENTMT PLC ORD SHS DELETED
G5258J 90 9 KING DIGITAL ENTMT PLC CALL DELETED
CUSIP NO ISSUER NAME ISSUER DESCRIPTION STATUS
8:54 IVM001
Run Date: 4/5/2016 ** List of Section 13F Securities ** Page 9
Run Time: Year: 2016 Qtr: 1
G5258J 95 9 KING DIGITAL ENTMT PLC PUT DELETED
G5315B 10 7 * KOSMOS ENERGY LTD SHS
G5315B 90 7 KOSMOS ENERGY LTD CALL
G5315B 95 7 KOSMOS ENERGY LTD PUT
G54050 10 2 * LAZARD LTD SHS A
G54050 90 2 LAZARD LTD CALL
G54050 95 2 LAZARD LTD PUT
G5480U 10 4 * LIBERTY GLOBAL PLC SHS CL A
G5480U 90 4 LIBERTY GLOBAL PLC CALL
G5480U 95 4 LIBERTY GLOBAL PLC PUT
G5480U 11 2 LIBERTY GLOBAL PLC SHS CL B
G5480U 12 0 * LIBERTY GLOBAL PLC SHS CL C
G5480U 90 0 LIBERTY GLOBAL PLC CALL
G5480U 95 0 LIBERTY GLOBAL PLC PUT
G5480U 13 8 LIBERTY GLOBAL PLC LILAC SHS CL A
G5480U 15 3 * LIBERTY GLOBAL PLC LILAC SHS CL C
G5480U 90 3 LIBERTY GLOBAL PLC CALL
G5480U 95 3 LIBERTY GLOBAL PLC PUT
G5509L 10 1 * LIVANOVA PLC SHS
G5509L 90 1 LIVANOVA PLC CALL
G5509L 95 1 LIVANOVA PLC PUT
G55598 10 9 LOMBARD MED INC COM
G57279 10 4 * LUXOFT HLDG INC ORD SHS CL A
G57279 90 4 LUXOFT HLDG INC CALL
G57279 95 4 LUXOFT HLDG INC PUT
G5753U 11 2 * MAIDEN HOLDINGS LTD SHS
G5753U 90 2 MAIDEN HOLDINGS LTD CALL
G5753U 95 2 MAIDEN HOLDINGS LTD PUT
G5784H 10 6 * MANCHESTER UTD PLC NEW ORD CL A
G5784H 90 6 MANCHESTER UTD PLC NEW CALL
G5784H 95 6 MANCHESTER UTD PLC NEW PUT
G5785G 10 7 * MALLINCKRODT PUB LTD CO SHS
G5785G 90 7 MALLINCKRODT PUB LTD CO CALL
G5785G 95 7 MALLINCKRODT PUB LTD CO PUT
CUSIP NO ISSUER NAME ISSUER DESCRIPTION STATUS
8:54 IVM001
Run Date: 4/5/2016 ** List of Section 13F Securities ** Page 10
Run Time: Year: 2016 Qtr: 1
G58249 10 6 * MARKIT LTD SHS
G58249 90 6 MARKIT LTD CALL
G58249 95 6 MARKIT LTD PUT
G5866L 10 8 GARNERO GROUP ACQUISITION CO SHS
G5866L 11 6 GARNERO GROUP ACQUISITION CO *W EXP 06/24/201
G5866L 12 4 GARNERO GROUP ACQUISITION CO UNIT 06/25/2016
G5866L 13 2 GARNERO GROUP ACQUISITION CO RIGHT 06/25/2016
G5876H 10 5 * MARVELL TECHNOLOGY GROUP LTD ORD
G5876H 90 5 MARVELL TECHNOLOGY GROUP LTD CALL
G5876H 95 5 MARVELL TECHNOLOGY GROUP LTD PUT
G5960L 10 3 * MEDTRONIC PLC SHS
G5960L 90 3 MEDTRONIC PLC CALL
G5960L 95 3 MEDTRONIC PLC PUT
G60754 10 1 * MICHAEL KORS HLDGS LTD SHS
G60754 90 1 MICHAEL KORS HLDGS LTD CALL
G60754 95 1 MICHAEL KORS HLDGS LTD PUT
G6331P 10 4 * ALPHA & OMEGA SEMICONDUCTOR SHS
G6331P 90 4 ALPHA & OMEGA SEMICONDUCTOR CALL
G6331P 95 4 ALPHA & OMEGA SEMICONDUCTOR PUT
G6331W 10 9 MULTI PACKAGING SOLUTIONS IN COM
G6359F 10 3 * NABORS INDUSTRIES LTD SHS
G6359F 90 3 NABORS INDUSTRIES LTD CALL
G6359F 95 3 NABORS INDUSTRIES LTD PUT
G63907 10 2 * NAM TAI PPTY INC SHS
G63907 90 2 NAM TAI PPTY INC CALL
G63907 95 2 NAM TAI PPTY INC PUT
G6503X 10 9 NEXVET BIOPHARMA PUB LTD CO ORD SHS
G6518L 10 8 * NIELSEN HLDGS PLC SHS EUR
G6518L 90 8 NIELSEN HLDGS PLC CALL
G6518L 95 8 NIELSEN HLDGS PLC PUT
G65431 10 1 * NOBLE CORP PLC SHS USD
G65431 90 1 NOBLE CORP PLC CALL
G65431 95 1 NOBLE CORP PLC PUT
G6564A 10 5 NOMAD HLDGS LTD USD ORD SHS ADDED
CUSIP NO ISSUER NAME ISSUER DESCRIPTION STATUS
8:54 IVM001
Run Date: 4/5/2016 ** List of Section 13F Securities ** Page 11
Run Time: Year: 2016 Qtr: 1
G65773 10 6 * NORDIC AMERICAN TANKERS LIMI COM
G65773 90 6 NORDIC AMERICAN TANKERS LIMI CALL
G65773 95 6 NORDIC AMERICAN TANKERS LIMI PUT
G6583A 10 2 * NORD ANGLIA EDUCATION INC SHS
G6583A 90 2 NORD ANGLIA EDUCATION INC CALL
G6583A 95 2 NORD ANGLIA EDUCATION INC PUT
G6613P 12 9 * NORTH ATLANTIC DRILLING LTD COM
G6613P 90 9 NORTH ATLANTIC DRILLING LTD CALL
G6613P 95 9 NORTH ATLANTIC DRILLING LTD PUT
G66721 10 4 * NORWEGIAN CRUISE LINE HLDGS SHS
G66721 90 4 NORWEGIAN CRUISE LINE HLDGS CALL
G66721 95 4 NORWEGIAN CRUISE LINE HLDGS PUT
G6674U 10 8 * NOVOCURE LTD ORD SHS
G6674U 90 8 NOVOCURE LTD CALL
G6674U 95 8 NOVOCURE LTD PUT
G67506 10 8 * OM ASSET MGMT PLC SHS
G67506 90 8 OM ASSET MGMT PLC CALL
G67506 95 8 OM ASSET MGMT PLC PUT
G67742 10 9 * ONEBEACON INSURANCE GROUP LT CL A
G67742 90 9 ONEBEACON INSURANCE GROUP LT CALL
G67742 95 9 ONEBEACON INSURANCE GROUP LT PUT
G67828 10 6 * ORIGIN AGRITECH LIMITED SHS
G67828 90 6 ORIGIN AGRITECH LIMITED CALL
G67828 95 6 ORIGIN AGRITECH LIMITED PUT
G6852T 10 5 * PARTNERRE LTD COM DELETED
G6852T 90 5 PARTNERRE LTD CALL DELETED
G6852T 95 5 PARTNERRE LTD PUT DELETED
G6855A 10 3 OXFORD IMMUNOTEC GLOBAL PLC ORD SHS
G6856M 10 6 OXBRIDGE RE HLDGS LTD SHS
G6856M 11 4 OXBRIDGE RE HLDGS LTD *W EXP 03/26/201
G68588 10 5 PACIFIC SPL ACQUISITION CORP SHS
G68588 11 3 PACIFIC SPL ACQUISITION CORP RIGHT 03/15/2017
G68588 12 1 PACIFIC SPL ACQUISITION CORP *W EXP 10/20/202
G68588 13 9 PACIFIC SPL ACQUISITION CORP UNIT 99/99/9999
CUSIP NO ISSUER NAME ISSUER DESCRIPTION STATUS
8:54 IVM001
Run Date: 4/5/2016 ** List of Section 13F Securities ** Page 12
Run Time: Year: 2016 Qtr: 1
G6865N 10 3 PACE HLDGS CORP CL A
G6865N 11 1 PACE HLDGS CORP *W EXP 99/99/999
G6865N 12 9 PACE HLDGS CORP UNIT 99/99/9999
G6891L 10 5 PANGAEA LOGISTICS SOLUTION L SHS
G7S00T 10 4 * PENTAIR PLC SHS
G7S00T 90 4 PENTAIR PLC CALL
G7S00T 95 4 PENTAIR PLC PUT
G7114V 10 2 PINGTAN MARINE ENTERPRISE LT SHS
G7234P 10 0 PRESBIA PLC SHS
G72800 10 8 * PROTHENA CORP PLC SHS
G72800 90 8 PROTHENA CORP PLC CALL
G72800 95 8 PROTHENA CORP PLC PUT
G73268 10 7 QUOTIENT LTD SHS
G7415M 10 8 RECON TECHNOLOGY LTD SHS
G7496G 10 3 * RENAISSANCERE HOLDINGS LTD COM
G7496G 90 3 RENAISSANCERE HOLDINGS LTD CALL
G7496G 95 3 RENAISSANCERE HOLDINGS LTD PUT
G7665A 10 1 * ROWAN COMPANIES PLC SHS CL A
G7665A 90 1 ROWAN COMPANIES PLC CALL
G7665A 95 1 ROWAN COMPANIES PLC PUT
G7945E 10 5 * SEADRILL LIMITED SHS
G7945E 90 5 SEADRILL LIMITED CALL
G7945E 95 5 SEADRILL LIMITED PUT
G7945M 10 7 * SEAGATE TECHNOLOGY PLC SHS
G7945M 90 7 SEAGATE TECHNOLOGY PLC CALL
G7945M 95 7 SEAGATE TECHNOLOGY PLC PUT
G80751 10 3 SGOCO GROUP LTD SHS DELETED
G80751 12 9 SGOCO GROUP LTD SHS NEW ADDED
G81075 AE 6 SHIP FINANCE INTERNATIONAL L NOTE 3.250% 2/0
G81075 10 6 * SHIP FINANCE INTERNATIONAL L SHS
G81075 90 6 SHIP FINANCE INTERNATIONAL L CALL
G81075 95 6 SHIP FINANCE INTERNATIONAL L PUT
G81276 10 0 * SIGNET JEWELERS LIMITED SHS
G81276 90 0 SIGNET JEWELERS LIMITED CALL
CUSIP NO ISSUER NAME ISSUER DESCRIPTION STATUS
8:54 IVM001
Run Date: 4/5/2016 ** List of Section 13F Securities ** Page 13
Run Time: Year: 2016 Qtr: 1
G81276 95 0 SIGNET JEWELERS LIMITED PUT
G81477 10 4 * SINA CORP ORD
G81477 90 4 SINA CORP CALL
G81477 95 4 SINA CORP PUT
G84720 10 4 * STERIS PLC SHS USD
G84720 90 4 STERIS PLC CALL
G84720 95 4 STERIS PLC PUT
G8477B 10 5 DELTA TECHNOLOGY HLDGS LTD USD ORD SHS
G8477B 11 3 DELTA TECHNOLOGY HLDGS LTD *W EXP 12/18/201
G85347 10 5 STRONGBRIDGE BIOPHARMA PLC SHS USD
G8663P AA 6 TAL ED GROUP DEBT 2.500% 5/1
G8675X 10 7 TANTECH HLDGS LTD COM
G87210 10 3 * UTI WORLDWIDE INC ORD DELETED
G87210 90 3 UTI WORLDWIDE INC CALL DELETED
G87210 95 3 UTI WORLDWIDE INC PUT DELETED
G87264 10 0 TECNOGLASS INC SHS
G8766E 10 9 * TEXTAINER GROUP HOLDINGS LTD SHS
G8766E 90 9 TEXTAINER GROUP HOLDINGS LTD CALL
G8766E 95 9 TEXTAINER GROUP HOLDINGS LTD PUT
G8789K 10 8 ABILITY INC SHS
G8789K 11 6 ABILITY INC *W EXP 12/17/201 DELETED
G8807B 10 6 * THERAVANCE BIOPHARMA INC COM
G8807B 90 6 THERAVANCE BIOPHARMA INC CALL
G8807B 95 6 THERAVANCE BIOPHARMA INC PUT
G8827U 10 0 * THIRD PT REINS LTD COM
G8827U 90 0 THIRD PT REINS LTD CALL
G8827U 95 0 THIRD PT REINS LTD PUT
G8875E 10 7 TILL CAP LTD COM RST VTG SHS
G89982 11 3 * TRANSATLANTIC PETROLEUM LTD SHS NEW
G89982 90 3 TRANSATLANTIC PETROLEUM LTD CALL
G89982 95 3 TRANSATLANTIC PETROLEUM LTD PUT
G9019D 10 4 * TRAVELPORT WORLDWIDE LTD SHS
G9019D 90 4 TRAVELPORT WORLDWIDE LTD CALL
G9019D 95 4 TRAVELPORT WORLDWIDE LTD PUT
CUSIP NO ISSUER NAME ISSUER DESCRIPTION STATUS';
my $regex = qr/^([\w\d]{6})\s([\w\d]{2})\s+([\w\d]{1})\s+((\*)\s)?(.*)((NOTE|ORD|COM|CALL|PUT|PFD|OPTION|PARTNERSHIP\sUNIT|INT\sUNI|RIGHT|ORD|NAMEN\sAKT|DBCV|CL\sA|\*W|DEBT|SHS|UNIT).*)(DELETED|ADDED)?$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}