import re
regex = re.compile(r"^([\w\d]{6})\s([\w\d]{2})\s+([\w\d]{1})\s+((\*)\s)?(.*)((NOTE|ORD|COM|CALL|PUT|PFD|OPTION|PARTNERSHIP\sUNIT|INT\sUNI|RIGHT|ORD|NAMEN\sAKT|DBCV|CL\sA|\*W|DEBT|SHS|UNIT).*)(DELETED|ADDED)?$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("G06242 90 4 ATLASSIAN CORP PLC CALL\n"
"G06242 95 4 ATLASSIAN CORP PLC PUT\n"
"G0692U 10 9 * AXIS CAPITAL HOLDINGS LTD SHS\n"
"G0692U 90 9 AXIS CAPITAL HOLDINGS LTD CALL\n"
"G0692U 95 9 AXIS CAPITAL HOLDINGS LTD PUT\n"
"G07021 12 7 * CHC GROUP LTD SHS NEW DELETED\n"
"G07021 90 7 CHC GROUP LTD CALL DELETED\n"
"G07021 95 7 CHC GROUP LTD PUT DELETED\n"
"G0750C 10 8 * AXALTA COATING SYS LTD COM\n"
"G0750C 90 8 AXALTA COATING SYS LTD CALL\n"
"G0750C 95 8 AXALTA COATING SYS LTD PUT\n"
"G0750W 10 4 * AXOVANT SCIENCES LTD COM\n"
"G0750W 90 4 AXOVANT SCIENCES LTD CALL\n"
"G0750W 95 4 AXOVANT SCIENCES LTD PUT\n"
"G10082 14 0 * ENERGY XXI LTD USD UNRS SHS\n"
"G10082 90 0 ENERGY XXI LTD CALL\n"
"G10082 95 0 ENERGY XXI LTD PUT\n"
"G1151C 10 1 * ACCENTURE PLC IRELAND SHS CLASS A\n"
"G1151C 90 1 ACCENTURE PLC IRELAND CALL\n"
"G1151C 95 1 ACCENTURE PLC IRELAND PUT\n"
"G1154H 10 7 * BELMOND LTD CL A\n"
"G1154H 90 7 BELMOND LTD CALL\n"
"G1154H 95 7 BELMOND LTD PUT\n"
"G1190F 10 7 BLUE CAP REINS HLDGS LTD COM\n"
"G14838 10 9 MIMECAST LTD ORD SHS\n"
"G16249 10 7 * BROOKFIELD PPTY PARTNERS L P UNIT LTD PARTN\n"
"G16249 90 7 BROOKFIELD PPTY PARTNERS L P CALL\n"
"G16249 95 7 BROOKFIELD PPTY PARTNERS L P PUT\n"
"G16252 10 1 * BROOKFIELD INFRAST PARTNERS LP INT UNIT\n"
"G16252 90 1 BROOKFIELD INFRAST PARTNERS CALL\n"
"G16252 95 1 BROOKFIELD INFRAST PARTNERS PUT\n"
"G16258 10 8 * BROOKFIELD RENEWABLE ENRGY P PARTNERSHIP UNIT\n"
"G16258 90 8 BROOKFIELD RENEWABLE ENRGY P CALL\n"
"G16258 95 8 BROOKFIELD RENEWABLE ENRGY P PUT\n"
"CUSIP NO ISSUER NAME ISSUER DESCRIPTION STATUS\n"
"8:54 IVM001\n"
"Run Date: 4/5/2016 ** List of Section 13F Securities ** Page 4\n"
"Run Time: Year: 2016 Qtr: 1\n"
"G16962 10 5 * BUNGE LIMITED COM\n"
"G16962 90 5 BUNGE LIMITED CALL\n"
"G16962 95 5 BUNGE LIMITED PUT\n"
"G20045 20 2 * CENTRAL EUROPEAN MEDIA ENTRP CL A NEW\n"
"G20045 90 2 CENTRAL EUROPEAN MEDIA ENTRP CALL\n"
"G20045 95 2 CENTRAL EUROPEAN MEDIA ENTRP PUT\n"
"G2029P 10 0 C B PHARMA ACQUISITION CORP UNIT 12/17/2021\n"
"G2029P 11 8 C B PHARMA ACQUISITION CORP *W EXP 12/17/202\n"
"G2029P 12 6 C B PHARMA ACQUISITION CORP SHS\n"
"G2029P 13 4 C B PHARMA ACQUISITION CORP RIGHT 06/17/2016\n"
"G21082 10 5 * CHINA YUCHAI INTL LTD COM\n"
"G21082 90 5 CHINA YUCHAI INTL LTD CALL\n"
"G21082 95 5 CHINA YUCHAI INTL LTD PUT\n"
"G2110R 11 4 * CHIPMOS TECH BERMUDA LTD SHS\n"
"G2110R 90 4 CHIPMOS TECH BERMUDA LTD CALL\n"
"G2110R 95 4 CHIPMOS TECH BERMUDA LTD PUT\n"
"G2110U 10 9 CHINA NATURAL RESOURCES INC COM\n"
"G21107 10 0 CHINA CORD BLOOD CORP SHS\n"
"G2113X 10 0 CHINA CERAMICS CO LTD SHS\n"
"G21174 10 0 * CHINA INFORMATION TECHNOLOGY COM\n"
"G21174 90 0 CHINA INFORMATION TECHNOLOGY CALL\n"
"G21174 95 0 CHINA INFORMATION TECHNOLOGY PUT\n"
"G2118P 10 2 CHINA CUST RELATIONS CNTR IN COM\n"
"G23773 10 7 * CONSOLIDATED WATER CO INC ORD\n"
"G23773 90 7 CONSOLIDATED WATER CO INC CALL\n"
"G23773 95 7 CONSOLIDATED WATER CO INC PUT\n"
"G2519Y 10 8 * CREDICORP LTD COM\n"
"G2519Y 90 8 CREDICORP LTD CALL\n"
"G2519Y 95 8 CREDICORP LTD PUT\n"
"G25343 10 7 * COSAN LTD SHS A\n"
"G25343 90 7 COSAN LTD CALL\n"
"G25343 95 7 COSAN LTD PUT\n"
"G25861 AA 6 CTRIP COM INTERNATIONAL LTD DEBT 0.500% 9/1\n"
"G25861 AC 2 CTRIP COM INTERNATIONAL LTD DEBT 1.000% 7/0\n"
"CUSIP NO ISSUER NAME ISSUER DESCRIPTION STATUS\n"
"8:54 IVM001\n"
"Run Date: 4/5/2016 ** List of Section 13F Securities ** Page 5\n"
"Run Time: Year: 2016 Qtr: 1\n"
"G25861 AD 0 CTRIP COM INTERNATIONAL LTD DEBT 1.990% 7/0\n"
"G2615J 10 4 DT ASIA INVTS LTD SHS\n"
"G2615J 11 2 DT ASIA INVTS LTD RIGHT 03/30/2016\n"
"G2615J 12 0 DT ASIA INVTS LTD UNIT 03/29/2021T\n"
"G2615J 13 8 DT ASIA INVTS LTD *W EXP 03/29/202\n"
"G27010 10 0 DEHAIER MEDICAL SYSTEMS LIMI SHS\n"
"G27823 10 6 * DELPHI AUTOMOTIVE PLC SHS\n"
"G27823 90 6 DELPHI AUTOMOTIVE PLC CALL\n"
"G27823 95 6 DELPHI AUTOMOTIVE PLC PUT\n"
"G28195 10 8 DOUBLE EAGLE ACQUISITION COR UNIT 99/99/9999\n"
"G28195 11 6 DOUBLE EAGLE ACQUISITION COR *W EXP 09/16/202\n"
"G28195 12 4 DOUBLE EAGLE ACQUISITION COR COM\n"
"G29183 10 3 * EATON CORP PLC SHS\n"
"G29183 90 3 EATON CORP PLC CALL\n"
"G29183 95 3 EATON CORP PLC PUT\n"
"G2920Y 10 1 E COMPASS ACQUISITION CORP ORD SHS\n"
"G2920Y 11 9 E COMPASS ACQUISITION CORP RIGHT 02/18/2017\n"
"G2920Y 20 0 E COMPASS ACQUISITION CORP UNIT 99/99/9999\n"
"G29438 10 1 EFUTURE HOLDING INC SHS\n"
"G2952T AA 1 E HOUSE CHINA HOLDINGS LIMIT DEBT 2.750%12/1\n"
"G30397 10 6 * ENDURANCE SPECIALTY HLDGS LT SHS\n"
"G30397 90 6 ENDURANCE SPECIALTY HLDGS LT CALL\n"
"G30397 95 6 ENDURANCE SPECIALTY HLDGS LT PUT\n"
"G30401 10 6 * ENDO INTL PLC SHS\n"
"G30401 90 6 ENDO INTL PLC CALL\n"
"G30401 95 6 ENDO INTL PLC PUT\n"
"G3075P 10 1 ENSTAR GROUP LIMITED SHS\n"
"G3105C 10 4 ELECTRUM SPL ACQUISITION COR SHS\n"
"G3105C 11 2 ELECTRUM SPL ACQUISITION COR *W EXP 99/99/999\n"
"G3105C 12 0 ELECTRUM SPL ACQUISITION COR UNIT 99/99/9999\n"
"G3156P 10 3 * ASA GOLD AND PRECIOUS MTLS L SHS\n"
"G3156P 90 3 ASA GOLD AND PRECIOUS MTLS L CALL\n"
"G3156P 95 3 ASA GOLD AND PRECIOUS MTLS L PUT\n"
"G3157S 10 6 * ENSCO PLC SHS CLASS A\n"
"CUSIP NO ISSUER NAME ISSUER DESCRIPTION STATUS\n"
"8:54 IVM001\n"
"Run Date: 4/5/2016 ** List of Section 13F Securities ** Page 6\n"
"Run Time: Year: 2016 Qtr: 1\n"
"G3157S 90 6 ENSCO PLC CALL\n"
"G3157S 95 6 ENSCO PLC PUT\n"
"G3163G 10 4 CHINA METRO-RURAL HLDGS LTD SHS\n"
"G3164Q 10 1 * C&J ENERGY SVCS LTD SHS\n"
"G3164Q 90 1 C&J ENERGY SVCS LTD CALL\n"
"G3164Q 95 1 C&J ENERGY SVCS LTD PUT\n"
"G3198U 10 2 * ESSENT GROUP LTD COM\n"
"G3198U 90 2 ESSENT GROUP LTD CALL\n"
"G3198U 95 2 ESSENT GROUP LTD PUT\n"
"G32030 12 7 EURO TECH HOLDINGS CO LTD SHS NEW\n"
"G3223R 10 8 * EVEREST RE GROUP LTD COM\n"
"G3223R 90 8 EVEREST RE GROUP LTD CALL\n"
"G3223R 95 8 EVEREST RE GROUP LTD PUT\n"
"G3323L 10 0 * FABRINET SHS\n"
"G3323L 90 0 FABRINET CALL\n"
"G3323L 95 0 FABRINET PUT\n"
"G33856 10 8 * FERROGLOBE PLC SHS\n"
"G33856 90 8 FERROGLOBE PLC CALL\n"
"G33856 95 8 FERROGLOBE PLC PUT\n"
"G35569 10 5 * FLEETMATICS GROUP PLC COM\n"
"G35569 90 5 FLEETMATICS GROUP PLC CALL\n"
"G35569 95 5 FLEETMATICS GROUP PLC PUT\n"
"G36738 10 5 * FRESH DEL MONTE PRODUCE INC ORD\n"
"G36738 90 5 FRESH DEL MONTE PRODUCE INC CALL\n"
"G36738 95 5 FRESH DEL MONTE PRODUCE INC PUT\n"
"G3682E 12 7 * FRONTLINE LTD SHS DELETED\n"
"G3682E 90 7 FRONTLINE LTD CALL DELETED\n"
"G3682E 95 7 FRONTLINE LTD PUT DELETED\n"
"G3682E 19 2 * FRONTLINE LTD SHS NEW ADDED\n"
"G3682E 90 2 FRONTLINE LTD CALL ADDED\n"
"G3682E 95 2 FRONTLINE LTD PUT ADDED\n"
"G3704F 10 2 FUWEI FILMS HLDGS CO LTD SHS\n"
"G3729B 10 2 FULING GLOBAL INC SHS\n"
"G37585 10 9 * GASLOG LTD SHS\n"
"CUSIP NO ISSUER NAME ISSUER DESCRIPTION STATUS\n"
"8:54 IVM001\n"
"Run Date: 4/5/2016 ** List of Section 13F Securities ** Page 7\n"
"Run Time: Year: 2016 Qtr: 1\n"
"G37585 90 9 GASLOG LTD CALL\n"
"G37585 95 9 GASLOG LTD PUT\n"
"G3788M 11 4 * EROS INTL PLC SHS NEW\n"
"G3788M 90 4 EROS INTL PLC CALL\n"
"G3788M 95 4 EROS INTL PLC PUT\n"
"G38327 10 5 GEOPARK LTD USD SHS\n"
"G3922B 10 7 * GENPACT LIMITED SHS\n"
"G3922B 90 7 GENPACT LIMITED CALL\n"
"G3922B 95 7 GENPACT LIMITED PUT\n"
"G39300 10 1 GLOBAL SOURCES LTD ORD\n"
"G39319 10 1 * GLOBAL INDEMNITY PLC SHS\n"
"G39319 90 1 GLOBAL INDEMNITY PLC CALL\n"
"G39319 95 1 GLOBAL INDEMNITY PLC PUT\n"
"G39320 11 7 GLOBAL TECH ADVANCED INNOVAT SHS NEW DELETED\n"
"G39637 10 6 * GOLDEN OCEAN GROUP LTD SHS\n"
"G39637 90 6 GOLDEN OCEAN GROUP LTD CALL\n"
"G39637 95 6 GOLDEN OCEAN GROUP LTD PUT\n"
"G40357 10 8 GP INVTS ACQUISITION COR *W EXP 05/19/202\n"
"G40357 11 6 GP INVTS ACQUISITION COR UNIT 99/99/9999\n"
"G40357 12 4 GP INVTS ACQUISITION COR SHS\n"
"G4095J 10 9 * GREENLIGHT CAPITAL RE LTD CLASS A\n"
"G4095J 90 9 GREENLIGHT CAPITAL RE LTD CALL\n"
"G4095J 95 9 GREENLIGHT CAPITAL RE LTD PUT\n"
"G4388N 10 6 * HELEN OF TROY CORP LTD COM\n"
"G4388N 90 6 HELEN OF TROY CORP LTD CALL\n"
"G4388N 95 6 HELEN OF TROY CORP LTD PUT\n"
"G4412G 10 1 * HERBALIFE LTD COM USD SHS\n"
"G4412G 90 1 HERBALIFE LTD CALL\n"
"G4412G 95 1 HERBALIFE LTD PUT\n"
"G4481U 10 6 HIGHWAY HLDGS LTD ORD\n"
"G45667 10 5 * HOLLYSYS AUTOMATION TECHNOLO SHS\n"
"G45667 90 5 HOLLYSYS AUTOMATION TECHNOLO CALL\n"
"G45667 95 5 HOLLYSYS AUTOMATION TECHNOLO PUT\n"
"G4617B 10 5 * HORIZON PHARMA PLC SHS\n"
"CUSIP NO ISSUER NAME ISSUER DESCRIPTION STATUS\n"
"8:54 IVM001\n"
"Run Date: 4/5/2016 ** List of Section 13F Securities ** Page 8\n"
"Run Time: Year: 2016 Qtr: 1\n"
"G4617B 90 5 HORIZON PHARMA PLC CALL\n"
"G4617B 95 5 HORIZON PHARMA PLC PUT\n"
"G4705A 10 0 * ICON PLC SHS\n"
"G4705A 90 0 ICON PLC CALL\n"
"G4705A 95 0 ICON PLC PUT\n"
"G47204 10 5 * IAO KUN GROUP HLDG CO LTD ORD USD SHS\n"
"G47204 90 5 IAO KUN GROUP HLDG CO LTD CALL\n"
"G47204 95 5 IAO KUN GROUP HLDG CO LTD PUT\n"
"G47791 10 1 * INGERSOLL-RAND PLC SHS\n"
"G47791 90 1 INGERSOLL-RAND PLC CALL\n"
"G47791 95 1 INGERSOLL-RAND PLC PUT\n"
"G4783X 10 5 INNOCOLL HLDGS PLC SHS ADDED\n"
"G4863A 10 8 * INTERNATIONAL GAME TECHNOLOG SHS USD\n"
"G4863A 90 8 INTERNATIONAL GAME TECHNOLOG CALL\n"
"G4863A 95 8 INTERNATIONAL GAME TECHNOLOG PUT\n"
"G48833 10 0 * WEATHERFORD INTL PLC ORD SHS\n"
"G48833 90 0 WEATHERFORD INTL PLC CALL\n"
"G48833 95 0 WEATHERFORD INTL PLC PUT\n"
"G491BT 10 8 * INVESCO LTD SHS\n"
"G491BT 90 8 INVESCO LTD CALL\n"
"G491BT 95 8 INVESCO LTD PUT\n"
"G5005R 10 7 * JAMES RIV GROUP LTD COM\n"
"G5005R 90 7 JAMES RIV GROUP LTD CALL\n"
"G5005R 95 7 JAMES RIV GROUP LTD PUT\n"
"G50871 10 5 * JAZZ PHARMACEUTICALS PLC SHS USD\n"
"G50871 90 5 JAZZ PHARMACEUTICALS PLC CALL\n"
"G50871 95 5 JAZZ PHARMACEUTICALS PLC PUT\n"
"G5138L 10 0 * JINPAN INTL LTD ORD\n"
"G5138L 90 0 JINPAN INTL LTD CALL\n"
"G5138L 95 0 JINPAN INTL LTD PUT\n"
"G51385 AA 3 JINKOSOLAR HLDG CO LTD DEBT 4.000% 2/0\n"
"G52237 10 7 AVOLON HLDGS LTD COM DELETED\n"
"G5258J 10 9 * KING DIGITAL ENTMT PLC ORD SHS DELETED\n"
"G5258J 90 9 KING DIGITAL ENTMT PLC CALL DELETED\n"
"CUSIP NO ISSUER NAME ISSUER DESCRIPTION STATUS\n"
"8:54 IVM001\n"
"Run Date: 4/5/2016 ** List of Section 13F Securities ** Page 9\n"
"Run Time: Year: 2016 Qtr: 1\n"
"G5258J 95 9 KING DIGITAL ENTMT PLC PUT DELETED\n"
"G5315B 10 7 * KOSMOS ENERGY LTD SHS\n"
"G5315B 90 7 KOSMOS ENERGY LTD CALL\n"
"G5315B 95 7 KOSMOS ENERGY LTD PUT\n"
"G54050 10 2 * LAZARD LTD SHS A\n"
"G54050 90 2 LAZARD LTD CALL\n"
"G54050 95 2 LAZARD LTD PUT\n"
"G5480U 10 4 * LIBERTY GLOBAL PLC SHS CL A\n"
"G5480U 90 4 LIBERTY GLOBAL PLC CALL\n"
"G5480U 95 4 LIBERTY GLOBAL PLC PUT\n"
"G5480U 11 2 LIBERTY GLOBAL PLC SHS CL B\n"
"G5480U 12 0 * LIBERTY GLOBAL PLC SHS CL C\n"
"G5480U 90 0 LIBERTY GLOBAL PLC CALL\n"
"G5480U 95 0 LIBERTY GLOBAL PLC PUT\n"
"G5480U 13 8 LIBERTY GLOBAL PLC LILAC SHS CL A\n"
"G5480U 15 3 * LIBERTY GLOBAL PLC LILAC SHS CL C\n"
"G5480U 90 3 LIBERTY GLOBAL PLC CALL\n"
"G5480U 95 3 LIBERTY GLOBAL PLC PUT\n"
"G5509L 10 1 * LIVANOVA PLC SHS\n"
"G5509L 90 1 LIVANOVA PLC CALL\n"
"G5509L 95 1 LIVANOVA PLC PUT\n"
"G55598 10 9 LOMBARD MED INC COM\n"
"G57279 10 4 * LUXOFT HLDG INC ORD SHS CL A\n"
"G57279 90 4 LUXOFT HLDG INC CALL\n"
"G57279 95 4 LUXOFT HLDG INC PUT\n"
"G5753U 11 2 * MAIDEN HOLDINGS LTD SHS\n"
"G5753U 90 2 MAIDEN HOLDINGS LTD CALL\n"
"G5753U 95 2 MAIDEN HOLDINGS LTD PUT\n"
"G5784H 10 6 * MANCHESTER UTD PLC NEW ORD CL A\n"
"G5784H 90 6 MANCHESTER UTD PLC NEW CALL\n"
"G5784H 95 6 MANCHESTER UTD PLC NEW PUT\n"
"G5785G 10 7 * MALLINCKRODT PUB LTD CO SHS\n"
"G5785G 90 7 MALLINCKRODT PUB LTD CO CALL\n"
"G5785G 95 7 MALLINCKRODT PUB LTD CO PUT\n"
"CUSIP NO ISSUER NAME ISSUER DESCRIPTION STATUS\n"
"8:54 IVM001\n"
"Run Date: 4/5/2016 ** List of Section 13F Securities ** Page 10\n"
"Run Time: Year: 2016 Qtr: 1\n"
"G58249 10 6 * MARKIT LTD SHS\n"
"G58249 90 6 MARKIT LTD CALL\n"
"G58249 95 6 MARKIT LTD PUT\n"
"G5866L 10 8 GARNERO GROUP ACQUISITION CO SHS\n"
"G5866L 11 6 GARNERO GROUP ACQUISITION CO *W EXP 06/24/201\n"
"G5866L 12 4 GARNERO GROUP ACQUISITION CO UNIT 06/25/2016\n"
"G5866L 13 2 GARNERO GROUP ACQUISITION CO RIGHT 06/25/2016\n"
"G5876H 10 5 * MARVELL TECHNOLOGY GROUP LTD ORD\n"
"G5876H 90 5 MARVELL TECHNOLOGY GROUP LTD CALL\n"
"G5876H 95 5 MARVELL TECHNOLOGY GROUP LTD PUT\n"
"G5960L 10 3 * MEDTRONIC PLC SHS\n"
"G5960L 90 3 MEDTRONIC PLC CALL\n"
"G5960L 95 3 MEDTRONIC PLC PUT\n"
"G60754 10 1 * MICHAEL KORS HLDGS LTD SHS\n"
"G60754 90 1 MICHAEL KORS HLDGS LTD CALL\n"
"G60754 95 1 MICHAEL KORS HLDGS LTD PUT\n"
"G6331P 10 4 * ALPHA & OMEGA SEMICONDUCTOR SHS\n"
"G6331P 90 4 ALPHA & OMEGA SEMICONDUCTOR CALL\n"
"G6331P 95 4 ALPHA & OMEGA SEMICONDUCTOR PUT\n"
"G6331W 10 9 MULTI PACKAGING SOLUTIONS IN COM\n"
"G6359F 10 3 * NABORS INDUSTRIES LTD SHS\n"
"G6359F 90 3 NABORS INDUSTRIES LTD CALL\n"
"G6359F 95 3 NABORS INDUSTRIES LTD PUT\n"
"G63907 10 2 * NAM TAI PPTY INC SHS\n"
"G63907 90 2 NAM TAI PPTY INC CALL\n"
"G63907 95 2 NAM TAI PPTY INC PUT\n"
"G6503X 10 9 NEXVET BIOPHARMA PUB LTD CO ORD SHS\n"
"G6518L 10 8 * NIELSEN HLDGS PLC SHS EUR\n"
"G6518L 90 8 NIELSEN HLDGS PLC CALL\n"
"G6518L 95 8 NIELSEN HLDGS PLC PUT\n"
"G65431 10 1 * NOBLE CORP PLC SHS USD\n"
"G65431 90 1 NOBLE CORP PLC CALL\n"
"G65431 95 1 NOBLE CORP PLC PUT\n"
"G6564A 10 5 NOMAD HLDGS LTD USD ORD SHS ADDED\n"
"CUSIP NO ISSUER NAME ISSUER DESCRIPTION STATUS\n"
"8:54 IVM001\n"
"Run Date: 4/5/2016 ** List of Section 13F Securities ** Page 11\n"
"Run Time: Year: 2016 Qtr: 1\n"
"G65773 10 6 * NORDIC AMERICAN TANKERS LIMI COM\n"
"G65773 90 6 NORDIC AMERICAN TANKERS LIMI CALL\n"
"G65773 95 6 NORDIC AMERICAN TANKERS LIMI PUT\n"
"G6583A 10 2 * NORD ANGLIA EDUCATION INC SHS\n"
"G6583A 90 2 NORD ANGLIA EDUCATION INC CALL\n"
"G6583A 95 2 NORD ANGLIA EDUCATION INC PUT\n"
"G6613P 12 9 * NORTH ATLANTIC DRILLING LTD COM\n"
"G6613P 90 9 NORTH ATLANTIC DRILLING LTD CALL\n"
"G6613P 95 9 NORTH ATLANTIC DRILLING LTD PUT\n"
"G66721 10 4 * NORWEGIAN CRUISE LINE HLDGS SHS\n"
"G66721 90 4 NORWEGIAN CRUISE LINE HLDGS CALL\n"
"G66721 95 4 NORWEGIAN CRUISE LINE HLDGS PUT\n"
"G6674U 10 8 * NOVOCURE LTD ORD SHS\n"
"G6674U 90 8 NOVOCURE LTD CALL\n"
"G6674U 95 8 NOVOCURE LTD PUT\n"
"G67506 10 8 * OM ASSET MGMT PLC SHS\n"
"G67506 90 8 OM ASSET MGMT PLC CALL\n"
"G67506 95 8 OM ASSET MGMT PLC PUT\n"
"G67742 10 9 * ONEBEACON INSURANCE GROUP LT CL A\n"
"G67742 90 9 ONEBEACON INSURANCE GROUP LT CALL\n"
"G67742 95 9 ONEBEACON INSURANCE GROUP LT PUT\n"
"G67828 10 6 * ORIGIN AGRITECH LIMITED SHS\n"
"G67828 90 6 ORIGIN AGRITECH LIMITED CALL\n"
"G67828 95 6 ORIGIN AGRITECH LIMITED PUT\n"
"G6852T 10 5 * PARTNERRE LTD COM DELETED\n"
"G6852T 90 5 PARTNERRE LTD CALL DELETED\n"
"G6852T 95 5 PARTNERRE LTD PUT DELETED\n"
"G6855A 10 3 OXFORD IMMUNOTEC GLOBAL PLC ORD SHS\n"
"G6856M 10 6 OXBRIDGE RE HLDGS LTD SHS\n"
"G6856M 11 4 OXBRIDGE RE HLDGS LTD *W EXP 03/26/201\n"
"G68588 10 5 PACIFIC SPL ACQUISITION CORP SHS\n"
"G68588 11 3 PACIFIC SPL ACQUISITION CORP RIGHT 03/15/2017\n"
"G68588 12 1 PACIFIC SPL ACQUISITION CORP *W EXP 10/20/202\n"
"G68588 13 9 PACIFIC SPL ACQUISITION CORP UNIT 99/99/9999\n"
"CUSIP NO ISSUER NAME ISSUER DESCRIPTION STATUS\n"
"8:54 IVM001\n"
"Run Date: 4/5/2016 ** List of Section 13F Securities ** Page 12\n"
"Run Time: Year: 2016 Qtr: 1\n"
"G6865N 10 3 PACE HLDGS CORP CL A\n"
"G6865N 11 1 PACE HLDGS CORP *W EXP 99/99/999\n"
"G6865N 12 9 PACE HLDGS CORP UNIT 99/99/9999\n"
"G6891L 10 5 PANGAEA LOGISTICS SOLUTION L SHS\n"
"G7S00T 10 4 * PENTAIR PLC SHS\n"
"G7S00T 90 4 PENTAIR PLC CALL\n"
"G7S00T 95 4 PENTAIR PLC PUT\n"
"G7114V 10 2 PINGTAN MARINE ENTERPRISE LT SHS\n"
"G7234P 10 0 PRESBIA PLC SHS\n"
"G72800 10 8 * PROTHENA CORP PLC SHS\n"
"G72800 90 8 PROTHENA CORP PLC CALL\n"
"G72800 95 8 PROTHENA CORP PLC PUT\n"
"G73268 10 7 QUOTIENT LTD SHS\n"
"G7415M 10 8 RECON TECHNOLOGY LTD SHS\n"
"G7496G 10 3 * RENAISSANCERE HOLDINGS LTD COM\n"
"G7496G 90 3 RENAISSANCERE HOLDINGS LTD CALL\n"
"G7496G 95 3 RENAISSANCERE HOLDINGS LTD PUT\n"
"G7665A 10 1 * ROWAN COMPANIES PLC SHS CL A\n"
"G7665A 90 1 ROWAN COMPANIES PLC CALL\n"
"G7665A 95 1 ROWAN COMPANIES PLC PUT\n"
"G7945E 10 5 * SEADRILL LIMITED SHS\n"
"G7945E 90 5 SEADRILL LIMITED CALL\n"
"G7945E 95 5 SEADRILL LIMITED PUT\n"
"G7945M 10 7 * SEAGATE TECHNOLOGY PLC SHS\n"
"G7945M 90 7 SEAGATE TECHNOLOGY PLC CALL\n"
"G7945M 95 7 SEAGATE TECHNOLOGY PLC PUT\n"
"G80751 10 3 SGOCO GROUP LTD SHS DELETED\n"
"G80751 12 9 SGOCO GROUP LTD SHS NEW ADDED\n"
"G81075 AE 6 SHIP FINANCE INTERNATIONAL L NOTE 3.250% 2/0\n"
"G81075 10 6 * SHIP FINANCE INTERNATIONAL L SHS\n"
"G81075 90 6 SHIP FINANCE INTERNATIONAL L CALL\n"
"G81075 95 6 SHIP FINANCE INTERNATIONAL L PUT\n"
"G81276 10 0 * SIGNET JEWELERS LIMITED SHS\n"
"G81276 90 0 SIGNET JEWELERS LIMITED CALL\n"
"CUSIP NO ISSUER NAME ISSUER DESCRIPTION STATUS\n"
"8:54 IVM001\n"
"Run Date: 4/5/2016 ** List of Section 13F Securities ** Page 13\n"
"Run Time: Year: 2016 Qtr: 1\n"
"G81276 95 0 SIGNET JEWELERS LIMITED PUT\n"
"G81477 10 4 * SINA CORP ORD\n"
"G81477 90 4 SINA CORP CALL\n"
"G81477 95 4 SINA CORP PUT\n"
"G84720 10 4 * STERIS PLC SHS USD\n"
"G84720 90 4 STERIS PLC CALL\n"
"G84720 95 4 STERIS PLC PUT\n"
"G8477B 10 5 DELTA TECHNOLOGY HLDGS LTD USD ORD SHS\n"
"G8477B 11 3 DELTA TECHNOLOGY HLDGS LTD *W EXP 12/18/201\n"
"G85347 10 5 STRONGBRIDGE BIOPHARMA PLC SHS USD\n"
"G8663P AA 6 TAL ED GROUP DEBT 2.500% 5/1\n"
"G8675X 10 7 TANTECH HLDGS LTD COM\n"
"G87210 10 3 * UTI WORLDWIDE INC ORD DELETED\n"
"G87210 90 3 UTI WORLDWIDE INC CALL DELETED\n"
"G87210 95 3 UTI WORLDWIDE INC PUT DELETED\n"
"G87264 10 0 TECNOGLASS INC SHS\n"
"G8766E 10 9 * TEXTAINER GROUP HOLDINGS LTD SHS\n"
"G8766E 90 9 TEXTAINER GROUP HOLDINGS LTD CALL\n"
"G8766E 95 9 TEXTAINER GROUP HOLDINGS LTD PUT\n"
"G8789K 10 8 ABILITY INC SHS\n"
"G8789K 11 6 ABILITY INC *W EXP 12/17/201 DELETED\n"
"G8807B 10 6 * THERAVANCE BIOPHARMA INC COM\n"
"G8807B 90 6 THERAVANCE BIOPHARMA INC CALL\n"
"G8807B 95 6 THERAVANCE BIOPHARMA INC PUT\n"
"G8827U 10 0 * THIRD PT REINS LTD COM\n"
"G8827U 90 0 THIRD PT REINS LTD CALL\n"
"G8827U 95 0 THIRD PT REINS LTD PUT\n"
"G8875E 10 7 TILL CAP LTD COM RST VTG SHS\n"
"G89982 11 3 * TRANSATLANTIC PETROLEUM LTD SHS NEW\n"
"G89982 90 3 TRANSATLANTIC PETROLEUM LTD CALL\n"
"G89982 95 3 TRANSATLANTIC PETROLEUM LTD PUT\n"
"G9019D 10 4 * TRAVELPORT WORLDWIDE LTD SHS\n"
"G9019D 90 4 TRAVELPORT WORLDWIDE LTD CALL\n"
"G9019D 95 4 TRAVELPORT WORLDWIDE LTD PUT\n"
"CUSIP NO ISSUER NAME ISSUER DESCRIPTION STATUS")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")