$re = '/((?:\/[\w.+-]+)+)/';
$str = 'libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf5431000)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);