import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\A(?:\\n+(?!SA21 abcdef$).*)*\\n*^(SA21 abcdef)$(?:\\n+(?!SA21 abcdef$).*)*\\z";
final String string = "SA21 abcdef\n"
+ "BKxyz\n"
+ "SA22 abcdef\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}