re = /\A(?:\n+(?!SA21 abcdef$).*)*\n*^(SA21 abcdef)$(?:\n+(?!SA21 abcdef$).*)*\z/m
str = 'SA21 abcdef
BKxyz
SA22 abcdef
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end