package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^1\s(\([0-9])[0-9]`)
var str = `1 (111)
1 1111`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}