package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{3}-\d{3}-\d{3}|\d{3}-\d{3})+(, \d{3}-\d{3}-\d{3}|\d{3}-\d{3})`)
var str = `123-456-789, 123-456
123-456, 123-456-789
123-456-789, 123-456-789,
123-456-789, 123-456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}