$re = '/^(\d{3}-\d{3}-\d{3}|\d{3}-\d{3})+(, \d{3}-\d{3}-\d{3}|\d{3}-\d{3})/m';
$str = '123-456-789, 123-456
123-456, 123-456-789
123-456-789, 123-456-789,
123-456-789, 123-456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);