import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http[\\w,=/:.-]+\\.(?:jpe?g|png|gif)";
final String string = "<a href=\"https://e...content-available-to-author-only...e.com/example1.jpg\">\n"
+ "<a href=\"https://e...content-available-to-author-only...e.com/ストスト.jpg\">\n"
+ "<a href=\"https://e...content-available-to-author-only...e.com/example3.jpg\">\n"
+ "<a href=\"example3.jpg\">";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}