import re
regex = re.compile(r"http[\w,=/:.-]+\.(?:jpe?g|png|gif)", flags=re.MULTILINE | re.UNICODE)
test_str = ("<a href=\"https://e...content-available-to-author-only...e.com/example1.jpg\">\n"
"<a href=\"https://e...content-available-to-author-only...e.com/ストスト.jpg\">\n"
"<a href=\"https://e...content-available-to-author-only...e.com/example3.jpg\">\n"
"<a href=\"example3.jpg\">")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")