$re = '@href="((?:http|\/\/)[^"]+\.(?:jpe?g|png|gif))"@mu';
$str = '<a href="https://e...content-available-to-author-only...e.com/example1.jpg">
<a href="https://e...content-available-to-author-only...e.com/ストスト.jpg">
<a href="https://e...content-available-to-author-only...e.com/example3.jpg">
<a href="example3.jpg">
<a href="https://e...content-available-to-author-only...e.com/exa.jpgmple3.exe">
<a href="https://e...content-available-to-author-only...e.com/example3.exe">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);