re = /href="((?:http|\/\/)[^"]+\.(?:jpe?g|png|gif))"/m
str = '<a href="https://e...content-available-to-author-only...e.com/example1.jpg">
<a href="https://e...content-available-to-author-only...e.com/ストスト.jpg">
<a href="https://e...content-available-to-author-only...e.com/example3.jpg">
<a href="example3.jpg">
<a href="https://e...content-available-to-author-only...e.com/exa.jpgmple3.exe">
<a href="https://e...content-available-to-author-only...e.com/example3.exe">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end