import re
regex = re.compile(r"((?!\d)[ぁ-んァ-ヶ一-龠、。!?…♡ー・\d]+(?<!\d))", flags=re.MULTILINE)
test_str = ("utf-8;TI\"うなだれる男性;T; I\"\n"
"utf-8;TI\";ボロボロの服の、座り込む品のある女性;T; I\"\n"
"utf-8;TI\"働く男性;T; I\"\n"
"utf-8;TI\"エルジオンの兵士;T; I\"\n"
"utf-8;TI\"子供;T; I\"\n"
"utf-8;TI\"男性;T; I\"\n"
"utf-8;TI\"アヤネ;T; I\"\n"
"utf-8;TI\"レイラ;T; I\"\n"
"utf-8;TI\"リコレ;T; I\"\n"
"utf-8;TI\"ニコル;T; I\"\n"
"utf-8;TI\"ラボへ;T; I\"\n"
"utf-8;TI\"レイラ外イベ;T; I\"\n"
"utf-8;TI\"リコレニコルモブ;T; I\"\n"
"utf-8;TI\" リコレ・ニコルイベ;T; I\"\n"
"utf-8;TI\"リコレ奥配置;T; I\"\n"
"utf-8;TI\"ニコル奥配置;T; I\"\n"
"utf-8;TI\"ミロ;T; I\"\n"
"utf-8;TI\"ミロイベモブ;T; I\"\n"
"utf-8;To;;;/;[i i i i i i i ;0@º'o;;;6;[ I\"#作れそうなひと……?;T; I\"\n"
"utf-8;TI\" ./data/img/faces/yull07.pis;Ti i ;0@º'o;;;3;[i'iI\" 帰還アイテムの禁止;T; I\"\n"
"utf-8;T;0['I\"中流エリアへ;T; I\"\n"
"utf-8;TI\"民家1へ;T; I\"\n"
"utf-8;TI\"民家2へ;T; I\"\n"
"utf-8;TI\"民家3へ;T; I\"\n"
"utf-8;TI\"レイラの家へ;T; I\"\n"
"utf-8;TI\"民家4へ;T; I\"\n"
"utf-8;TI\"ミロの家へ;T; I\"\n"
"utf-8;TI\"アルフィーネ;T; I\"\n"
"utf-8;TI\"最後の約束;T; I\"\n"
"utf-8;TI\"門番;T; I\"\n"
"utf-8;TI\"ごろつき;T; I\"\n"
"utf-8;TI\"うなだれる男性;T; I\"\n"
"utf-8;TI\";ボロボロの服の、座り込む品のある女性;T; I\"\n"
"utf-8;TI\"働く男性;T; I\"\n"
"utf-8;TI\"エルジオンの兵士;T; I\"\n"
"utf-8;TI\"子供;T; I\"\n"
"utf-8;TI\"男性;T; I\"\n"
"utf-8;TI\"アヤネ;T; I\"\n"
"utf-8;TI\"レイラ;T; I\"\n"
"utf-8;TI\"リコレ;T; I\"\n"
"utf-8;TI\"ニコル;T; I\"\n"
"utf-8;TI\"ラボへ;T; I\"\n"
"utf-8;TI\"レイラ外イベ;T; I\"\n"
"utf-8;TI\"リコレニコルモブ;T; I\"\n"
"utf-8;TI\" リコレ・ニコルイベ;T; I\"\n"
"utf-8;TI\"リコレ奥配置;T; I\"\n"
"utf-8;TI\"ニコル奥配置;T; I\"\n"
"utf-8;TI\"ミロ;T; I\"\n"
"utf-8;TI\"ミロイベモブ;T; I\"\n"
"utf-8;TI\"中流エリアへ;T; I\"\n"
"utf-8;TI\"中流帰還イベ;T; I\"\n"
"utf-8;TI\"ミロ外イベ;T; I\"\n"
"utf-8;TI\"義足ミロ;T; I\"\n"
"utf-8;TI\"使い捨てライター;T; I\"\n"
"utf-8;To;;;3;[i\n"
"'i I\"転送装置ON;T; I\"\n"
"utf-8;T;0['@@@1@U@b@o@@ª@욀µ@÷@ù@·@ý@☀@@I\"ラボへ;T; I\"\n"
"utf-8;T@ @@\n"
"@@I\"ミロ;T; I\"\n"
"utf-8;T@@I\"中流帰還イベ;T; I\"\n"
"utf-8;T@@@o;;;4;[i i#;0[\"I\"中流エリアへ;T; I\"\n"
"utf-8;TI\"民家1へ;T; I\"\n"
"utf-8;TI\"民家2へ;T; I\"\n"
"utf-8;TI\"民家3へ;T; I\"\n"
"utf-8;TI\"レイラの家へ;T; I\"\n"
"utf-8;TI\"民家4へ;T; I\"\n"
"utf-8;TI\"ミロの家へ;T; I\"\n"
"utf-8;TI\"アルフィーネ;T; I\"\n"
"utf-8;TI\"最後の約束;T; I\"\n"
"utf-8;TI\"門番;T; I\"\n"
"utf-8;TI\"ごろつき;T; I\"\n"
"utf-8;TI\"うなだれる男性;T; I\"\n"
"utf-8;TI\";ボロボロの服の、座り込む品のある女性;T; I\"\n"
"utf-8;TI\"働く男性;T; I\"\n"
"utf-8;TI\"エルジオンの兵士;T; I\"\n"
"utf-8;TI\"子供;T; I\"\n"
"utf-8;TI\"男性;T; I\"\n"
"utf-8;TI\"アヤネ;T; I\"\n"
"utf-8;TI\"レイラ;T; I\"\n"
"utf-8;TI\"リコレ;T; I\"\n"
"utf-8;TI\"ニコル;T; I\"\n"
"utf-8;TI\"ラボへ;T; I\"\n"
"utf-8;TI\"レイラ外イベ;T; I\"\n"
"utf-8;TI\"リコレニコルモブ;T; I\"\n"
"utf-8;TI\" リコレ・ニコルイベ;T; I\"\n"
"utf-8;TI\"リコレ奥配置;T; I\"\n"
"utf-8;TI\"ニコル奥配置;T; I\"\n"
"utf-8;TI\"ミロ;T; I\"\n"
"utf-8;TI\"noname;To;;;3;[iiI\"中流エリアイベ;T; I\"\n"
"utf-8;T;0@º'o;;;5;[i#;0[\"I\"中流エリアへ;T; I\"\n"
"utf-8;TI\"民家1へ;T; I\"\n"
"utf-8;TI\"民家2へ;T; I\"\n"
"utf-8;TI\"民家3へ;T; I\"\n"
"utf-8;TI\"レイラの家へ;T; I\"\n"
"utf-8;TI\"民家4へ;T; I\"\n"
"utf-8;TI\"ミロの家へ;T; I\"\n"
"utf-8;TI\"アルフィーネ;T; I\"\n"
"utf-8;TI\"最後の約束;T; I\"\n"
"utf-8;TI\"門番;T; I\"\n"
"utf-8;TI\"ごろつき;T; I\"\n"
"utf-8;TI\"うなだれる男性;T; I\"\n"
"utf-8;TI\";ボロボロの服の、座り込む品のある女性;T; I\"\n"
"utf-8;TI\"働く男性;T; I\"\n"
"utf-8;TI\"エルジオンの兵士;T; I\"\n"
"utf-8;TI\"子供;T; I\"\n"
"utf-8;TI\"男性;T; I\"\n"
"utf-8;TI\"アヤネ;T; I\"\n"
"utf-8;TI\"レイラ;T; I\"\n"
"utf-8;TI\"リコレ;T; I\"\n"
"utf-8;TI\"ニコル;T; I\"\n"
"utf-8;TI\"ラボへ;T; I\"\n"
"utf-8;TI\"レイラ外イベ;T; I\"\n"
"utf-8;TI\"リコレニコルモブ;T; I\"\n"
"utf-8;TI\" リコレ・ニコルイベ;T; I\"\n"
"utf-8;TI\"リコレ奥配置;T; I\"\n"
"utf-8;TI\"ニコル奥配置;T; I\"\n"
"utf-8;TI\"ミロ;T; I\"\n"
"utf-8;TI\"noname;To;;;3;[ii I\"ミロ解放;T; I\"\n"
"utf-8;T;0@º';i ;i ;i;i ;i ; i ;!i ;\"i;#i ;$i ;%i ;&i ;'i ;(i ;)i o;;i ;i ;i ;i ;i ;[o;;;6;[ I\"Bべつにいいですよ?\n"
"構わないでください……;T; I\"\n"
"utf-8;TI\"./data/img/faces/074.pis;Ti i ;0[\"I\"中流エリアへ;T; I\"\n"
"utf-8;TI\"民家1へ;T; I\"\n"
"utf-8;TI\"民家2へ;T; I\"\n"
"utf-8;TI\"民家3へ;T; I\"\n"
"utf-8;TI\"レイラの家へ;T; I\"\n"
"utf-8;TI\"民家4へ;T; I\"\n"
"utf-8;TI\"ミロの家へ;T; I\"\n"
"utf-8;TI\"アルフィーネ;T; I\"\n"
"utf-8;TI\"最後の約束;T; I\"\n"
"utf-8;TI\"門番;T; I\"\n"
"utf-8;TI\"ごろつき;T; I\"\n"
"utf-8;TI\"うなだれる男性;T; I\"\n"
"utf-8;TI\";ボロボロの服の、座り込む品のある女性;T; I\"\n"
"utf-8;TI\"働く男性;T; I\"\n"
"utf-8;TI\"エルジオンの兵士;T; I\"\n"
"utf-8;TI\"子供;T; I\"\n"
"utf-8;TI\"男性;T; I\"\n"
"utf-8;TI\"アヤネ;T; I\"\n"
"utf-8;TI\"レイラ;T; I\"\n"
"utf-8;TI\"リコレ;T; I\"\n"
"utf-8;TI\"ニコル;T; I\"\n"
"utf-8;TI\"ラボへ;T; I\"\n"
"utf-8;TI\"レイラ外イベ;T; I\"\n"
"utf-8;TI\"リコレニコルモブ;T; I\"\n"
"utf-8;TI\" リコレ・ニコルイベ;T; I\"\n"
"utf-8;TI\"リコレ奥配置;T; I\"\n"
"utf-8;TI\"ニコル奥配置;T; I\"\n"
"utf-8;TI\"ミロ;T; I\"\n"
"utf-8;TI\"ミロイベモブ;T; I\"\n"
"utf-8;To;;;6;[ I\"<もうなにも\n"
"期待なんてしていませんから;T; I\"\n"
"utf-8;TI\"./data/img/faces/074.pis;Ti i ;0@ *;i ;i ;i;i ;i ; i ;!i ;\"i;#i ;$i ;%i ;&i ;'i ;(i ;)i o;;i ;i ;i ;i ;i ;[ ;i ;i ;i;i ;i ; i ;!i ;\"i;#i ;$i ;%i ;&i ;'i ;(i ;)i o;;i ;i ;i ;i ;i ;[/o;;;4;[i i#;0[\"I\"中流エリアへ;T; I\"\n"
"utf-8;TI\"民家1へ;T; I\"\n"
"utf-8;TI\"民家2へ;T; I\"\n"
"utf-8;TI\"民家3へ;T; I\"\n"
"utf-8;TI\"レイラの家へ;T; I\"\n"
"utf-8;TI\"民家4へ;T; I\"\n"
"utf-8;TI\"ミロの家へ;T; I\"\n"
"utf-8;TI\"アルフィーネ;T; I\"\n"
"utf-8;TI\"最後の約束;T; I\"\n"
"utf-8;TI\"門番;T; I\"\n"
"utf-8;TI\"ごろつき;T; I\"\n"
"utf-8;TI\"うなだれる男性;T; I\"\n"
"utf-8;TI\";ボロボロの服の、座り込む品のある女性;T; I\"\n"
"utf-8;TI\"働く男性;T; I\"\n"
"utf-8;TI\"エルジオンの兵士;T; I\"\n"
"utf-8;TI\"子供;T; I\"\n"
"utf-8;TI\"男性;T; I\"\n"
"utf-8;TI\"アヤネ;T; I\"\n"
"utf-8;TI\"レイラ;T; I\"\n"
"utf-8;TI\"リコレ;T; I\"\n"
"utf-8;TI\"ニコル;T; I\"\n"
"utf-8;TI\"ラボへ;T; I\"\n"
"utf-8;TI\"レイラ外イベ;T; I\"\n"
"utf-8;TI\"リコレニコルモブ;T; I\"\n"
"utf-8;TI\" リコレ・ニコルイベ;T; I\"\n"
"utf-8;TI\"リコレ奥配置;T; I\"\n"
"utf-8;TI\"ニコル奥配置;T; I\"\n"
"utf-8;TI\"ミロ;T; I\"\n"
"utf-8;TI\"noname;To;;;/;[i iĩi i ii;0[\"I\"中流エリアへ;T; I\"\n"
"utf-8;TI\"民家1へ;T; I\"\n"
"utf-8;TI\"民家2へ;T; I\"\n"
"utf-8;TI\"民家3へ;T; I\"\n"
"utf-8;TI\"レイラの家へ;T; I\"\n"
"utf-8;TI\"民家4へ;T; I\"\n"
"utf-8;TI\"ミロの家へ;T; I\"\n"
"utf-8;TI\"アルフィーネ;T; I\"\n"
"utf-8;TI\"最後の約束;T; I\"\n"
"utf-8;TI\"門番;T; I\"\n"
"utf-8;TI\"ごろつき;T; I\"\n"
"utf-8;TI\"うなだれる男性;T; I\"\n"
"utf-8;TI\";ボロボロの服の、座り込む品のある女性;T; I\"\n"
"utf-8;TI\"働く男性;T; I\"\n"
"utf-8;TI\"エルジオンの兵士;T; I\"\n"
"utf-8;TI\"子供;T; I\"\n"
"utf-8;TI\"男性;T; I\"\n"
"utf-8;TI\"アヤネ;T; I\"\n"
"utf-8;TI\"レイラ;T; I\"\n"
"utf-8;TI\"リコレ;T; I\"\n"
"utf-8;TI\"ニコル;T; I\"\n"
"utf-8;TI\"ラボへ;T; I\"\n"
"utf-8;TI\"レイラ外イベ;T; I\"\n"
"utf-8;TI\"リコレニコルモブ;T; I\"\n"
"utf-8;TI\" リコレ・ニコルイベ;T; I\"\n"
"utf-8;TI\"リコレ奥配置;T; I\"\n"
"utf-8;TI\"ニコル奥配置;T; I\"\n"
"utf-8;TI\"ミロ;T; I\"\n"
"utf-8;TI\"noname;To;;;5;[i#;0[\"I\"中流エリアへ;T; I\"\n"
"utf-8;TI\"民家1へ;T; I\"\n"
"utf-8;TI\"民家2へ;T; I\"\n"
"utf-8;TI\"民家3へ;T; I\"\n"
"utf-8;TI\"レイラの家へ;T; I\"\n"
"utf-8;TI\"民家4へ;T; I\"\n"
"utf-8;TI\"ミロの家へ;T; I\"\n"
"utf-8;TI\"アルフィーネ;T; I\"\n"
"utf-8;TI\"最後の約束;T; I\"\n"
"utf-8;TI\"門番;T; I\"\n"
"utf-8;TI\"ごろつき;T; I\"\n"
"utf-8;TI\"うなだれる男性;T; I\"\n"
"utf-8;TI\";ボロボロの服の、座り込む品のある女性;T; I\"\n"
"utf-8;TI\"働く男性;T; I\"\n"
"utf-8;TI\"エルジオンの兵士;T; I\"\n"
"utf-8;TI\"子供;T; I\"\n"
"utf-8;TI\"男性;T; I\"\n"
"utf-8;TI\"アヤネ;T; I\"\n"
"utf-8;TI\"レイラ;T; I\"\n"
"utf-8;TI\"リコレ;T; I\"\n"
"utf-8;TI\"ニコル;T; I\"\n"
"utf-8;TI\"ラボへ;T; I\"\n"
"utf-8;TI\"レイラ外イベ;T; I\"\n"
"utf-8;TI\"リコレニコルモブ;T; I\"\n"
"utf-8;TI\" リコレ・ニコルイベ;T; I\"\n"
"utf-8;TI\"リコレ奥配置;T; I\"\n"
"utf-8;TI\"ニコル奥配置;T; I\"\n"
"utf-8;TI\"ミロ;T; I\"\n"
"utf-8;TI\"noname;To;;;6;[ I\"――お待たせ!;T; I\"\n"
"utf-8;TI\" ./data/img/faces/yull14.pis;Ti i ;0[$I\"中流エリアへ;T; I\"\n"
"utf-8;TI\"民家1へ;T; I\"\n"
"utf-8;TI\"民家2へ;T; I\"\n"
"utf-8;TI\"民家3へ;T; I\"\n"
"utf-8;TI\"レイラの家へ;T; I\"\n"
"utf-8;TI\"民家4へ;T; I\"\n"
"utf-8;TI\"ミロの家へ;T; I\"\n"
"utf-8;TI\"アルフィーネ;T; I\"\n"
"utf-8;TI\"最後の約束;T; I\"\n"
"utf-8;TI\"門番;T; I\"\n"
"utf-8;TI\"ごろつき;T; I\"\n"
"utf-8;TI\"うなだれる男性;T; I\"\n"
"utf-8;TI\";ボロボロの服の、座り込む品のある女性;T; I\"\n"
"utf-8;TI\"働く男性;T; I\"\n"
"utf-8;TI\"エルジオンの兵士;T; I\"\n"
"utf-8;TI\"子供;T; I\"\n"
"utf-8;TI\"男性;T; I\"\n"
"utf-8;TI\"アヤネ;T; I\"\n"
"utf-8;TI\"レイラ;T; I\"\n"
"utf-8;TI\"リコレ;T; I\"\n"
"utf-8;TI\"ニコル;T; I\"\n"
"utf-8;TI\"ラボへ;T; I\"\n"
"utf-8;TI\"レイラ外イベ;T; I\"\n"
"utf-8;TI\"リコレニコルモブ;T; I\"\n"
"utf-8;TI\" リコレ・ニコルイベ;T; I\"\n"
"utf-8;TI\"リコレ奥配置;T; I\"\n"
"utf-8;TI\"ニコル奥配置;T; I\"\n"
"utf-8;TI\"ミロ;T; I\"\n"
"utf-8;TI\"ミロイベモブ;T; I\"\n"
"utf-8;TI\"中流エリアへ;T; I\"\n"
"utf-8;TI\"中流帰還イベ;T; I\"\n"
"utf-8;To;;;7;[\n"
"ii ;8i i ;0@+o;;;9;[iA;0[\"I\"中流エリアへ;T; I\"\n"
"utf-8;TI\"民家1へ;T; I\"\n"
"utf-8;TI\"民家2へ;T; I\"\n"
"utf-8;TI\"民家3へ;T; I\"\n"
"utf-8;TI\"レイラの家へ;T; I\"\n"
"utf-8;TI\"民家4へ;T; I\"\n"
"utf-8;TI\"ミロの家へ;T; I\"\n"
"utf-8;TI\"アルフィーネ;T; I\"\n"
"utf-8;TI\"最後の約束;T; I\"\n"
"utf-8;TI\"門番;T; I\"\n"
"utf-8;TI\"ごろつき;T; I\"\n"
"utf-8;TI\"うなだれる男性;T; I\"\n"
"utf-8;TI\";ボロボロの服の、座り込む品のある女性;T; I\"\n"
"utf-8;TI\"働く男性;T; I\"\n"
"utf-8;TI\"エルジオンの兵士;T; I\"\n"
"utf-8;TI\"子供;T; I\"\n"
"utf-8;TI\"男性;T; I\"\n"
"utf-8;TI\"アヤネ;T; I\"\n"
"utf-8;TI\"レイラ;T; I\"\n"
"utf-8;TI\"リコレ;T; I\"\n"
"utf-8;TI\"ニコル;T; I\"\n"
"utf-8;TI\"ラボへ;T; I\"\n"
"utf-8;TI\"レイラ外イベ;T; I\"\n"
"utf-8;TI\"リコレニコルモブ;T; I\"\n"
"utf-8;TI\" リコレ・ニコルイベ;T; I\"\n"
"utf-8;TI\"リコレ奥配置;T; I\"\n"
"utf-8;TI\"ニコル奥配置;T; I\"\n"
"utf-8;TI\"ミロ;T; I\"\n"
"utf-8;TI\"ミロイベモブ;T; I\"\n"
"utf-8;To;;;6;[ I\"'……えっ?\n"
"そ、それは?;T; I\"\n"
"utf-8;TI\"./data/img/faces/074.pis;Ti i ;0@+o;;;6;[ I\"&えへへ、すごいでしょ!;T; I\"\n"
"utf-8;TI\" ./data/img/faces/yull14.pis;Ti i ;0@+o;;;6;[ I\"=キミのために\n"
"作ってもらってきたんだ!\n"
";T; I\"\n"
"utf-8;TI\" ./data/img/faces/yull15.pis;Ti i ;0@+o;;;7;[\n"
"ii ;Li i ;0@+o;;;9;[i#;0@+o;;;6;[ I\"&わ、私にですか……!?;T; I\"\n"
"utf-8;TI\"./data/img/faces/074.pis;Ti i ;0@+o;;;6;[ I\"どうして……;T; I\"\n"
"utf-8;TI\"./data/img/faces/074.pis;Ti i ;0@+o;;;6;[ I\"9いいから!\n"
"……ほらっ、つけてみて!;T; I\"\n"
"utf-8;TI\" ./data/img/faces/yull14.pis;Ti i ;0@+o;;;6;[ I\"……は、はいっ!;T; I\"\n"
"utf-8;TI\"./data/img/faces/074.pis;Ti i ;0@+o;;;4;[i i#;0[\"I\"中流エリアへ;T; I\"\n"
"utf-8;TI\"民家1へ;T; I\"\n"
"utf-8;TI\"民家2へ;T; I\"\n"
"utf-8;TI\"民家3へ;T; I\"\n"
"utf-8;TI\"レイラの家へ;T; I\"\n"
"utf-8;TI\"民家4へ;T; I\"\n"
"utf-8;TI\"ミロの家へ;T; I\"\n"
"utf-8;TI\"アルフィーネ;T; I\"\n"
"utf-8;TI\"最後の約束;T; I\"\n"
"utf-8;TI\"門番;T; I\"\n"
"utf-8;TI\"ごろつき;T; I\"\n"
"utf-8;TI\"うなだれる男性;T; I\"\n"
"utf-8;TI\";ボロボロの服の、座り込む品のある女性;T; I\"\n"
"utf-8;TI\"働く男性;T; I\"\n"
"utf-8;TI\"エルジオンの兵士;T; I\"\n"
"utf-8;TI\"子供;T; I\"\n"
"utf-8;TI\"男性;T; I\"\n"
"utf-8;TI\"アヤネ;T; I\"\n"
"utf-8;TI\"レイラ;T; I\"\n"
"utf-8;TI\"リコレ;T; I\"\n"
"utf-8;TI\"ニコル;T; I\"\n"
"utf-8;TI\"ラボへ;T; I\"\n"
"utf-8;TI\"レイラ外イベ;T; I\"\n"
"utf-8;TI\"リコレニコルモブ;T; I\"\n"
"utf-8;TI\" リコレ・ニコルイベ;T; I\"\n"
"utf-8;TI\"リコレ奥配置;T; I\"\n"
"utf-8;TI\"ニコル奥配置;T; I\"\n"
"utf-8;TI\"ミロ;T; I\"\n"
"utf-8;TI\"noname;To;;;O;[Fi ;0@+o;;;3;[iiI\"義足装着後表示;T; I\"\n"
"utf-8;T;0@+o;;;5;[i#;0@+o;;;6;[ I\"<――す、すごいっ!\n"
"すごいですっ……!;T; I\"\n"
"utf-8;TI\"./data/img/faces/074.pis;Ti i ;0@+o;;;6;[ I\"Nこれ……、\n"
"私が頭で考えたとおりに動きます……っ!;T; I\"\n"
"utf-8;TI\"./data/img/faces/074.pis;Ti i ;0@+o;;;6;[ I\"9ホントだっ!\n"
"ちゃんと動いてる……!;T; I\"\n"
"utf-8;TI\" ./data/img/faces/yull14.pis;Ti i ;0@+o;;;6;[ I\"<嬉しい……っ!\n"
"私、また歩けます……!;T; I\"\n"
"utf-8;TI\"./data/img/faces/074.pis;Ti i ;0@+o;;;6;[ I\"&えへへ……よかったね!;T; I\"\n"
"utf-8;TI\" ./data/img/faces/yull15.pis;Ti i ;0@+o;;;6;[ I\"<よろこんでもらえて\n"
"ボクもうれしいよ!;T; I\"\n"
"utf-8;TI\" ./data/img/faces/yull15.pis;Ti i ;0@+o;;;6;[ I\"o……でも、どうして見ず知らずの私に\n"
"こんなにも良くしてくださるんですか?;T; I\"\n"
"utf-8;TI\"./data/img/faces/074.pis;Ti i ;0@+o;;;6;[ I\"-えっ……?\n"
"そ、そうだね……;T; I\"\n"
"utf-8;TI\" ./data/img/faces/yull07.pis;Ti i ;0@+o;;;7;[\n"
"ii;8i i ;0@+o;;;9;[iA;0[\"I\"中流エリアへ;T; I\"\n"
"utf-8;TI\"民家1へ;T; I\"\n"
"utf-8;TI\"民家2へ;T; I\"\n"
"utf-8;TI\"民家3へ;T; I\"\n"
"utf-8;TI\"レイラの家へ;T; I\"\n"
"utf-8;TI\"民家4へ;T; I\"\n"
"utf-8;TI\"ミロの家へ;T; I\"\n"
"utf-8;TI\"アルフィーネ;T; I\"\n"
"utf-8;TI\"最後の約束;T; I\"\n"
"utf-8;TI\"門番;T; I\"\n"
"utf-8;TI\"ごろつき;T; I\"\n"
"utf-8;TI\"うなだれる男性;T; I\"\n"
"utf-8;TI\";ボロボロの服の、座り込む品のある女性;T; I\"\n"
"utf-8;TI\"働く男性;T; I\"\n"
"utf-8;TI\"エルジオンの兵士;T; I\"\n"
"utf-8;TI\"子供;T; I\"\n"
"utf-8;TI\"男性;T; I\"\n"
"utf-8;TI\"アヤネ;T; I\"\n"
"utf-8;TI\"レイラ;T; I\"\n"
"utf-8;TI\"リコレ;T; I\"\n"
"utf-8;TI\"ニコル;T; I\"\n"
"utf-8;TI\"ラボへ;T; I\"\n"
"utf-8;TI\"レイラ外イベ;T; I\"\n"
"utf-8;TI\"リコレニコルモブ;T; I\"\n"
"utf-8;TI\" リコレ・ニコルイベ;T; I\"\n"
"utf-8;TI\"リコレ奥配置;T; I\"\n"
"utf-8;TI\"ニコル奥配置;T; I\"\n"
"utf-8;TI\"ミロ;T; I\"\n"
"utf-8;TI\"ミロイベモブ;T; I\"\n"
"utf-8;To;;;6;[ I\"&……なんとなく、かな?;T; I\"\n"
"utf-8;TI\" ./data/img/faces/yull12.pis;Ti i ;0@+o;;;6;[ I\";そ、そんなっ……なんとなくなんて……;T; I\"\n"
"utf-8;TI\"./data/img/faces/074.pis;Ti i ;0@+o;;;6;[ I\"&せ、せめてお礼を……!;T; I\"\n"
"utf-8;TI\"./data/img/faces/074.pis;Ti i ;0@+o;;;6;[ I\"3ええっ……!?\n"
"いいよそんなの!;T; I\"\n"
"utf-8;TI\" ./data/img/faces/yull10.pis;Ti i ;0[$I\"中流エリアへ;T; I\"\n"
"utf-8;TI\"民家1へ;T; I\"\n"
"utf-8;TI\"民家2へ;T; I\"\n"
"utf-8;TI\"民家3へ;T; I\"\n"
"utf-8;TI\"レイラの家へ;T; I\"\n"
"utf-8;TI\"民家4へ;T; I\"\n"
"utf-8;TI\"ミロの家へ;T; I\"\n"
"utf-8;TI\"アルフィーネ;T; I\"\n"
"utf-8;TI\"最後の約束;T; I\"\n"
"utf-8;TI\"門番;T; I\"\n"
"utf-8;TI\"ごろつき;T; I\"\n"
"utf-8;TI\"うなだれる男性;T; I\"\n"
"utf-8;TI\";ボロボロの服の、座り込む品のある女性;T; I\"\n"
"utf-8;TI\"働く男性;T; I\"\n"
"utf-8;TI\"エルジオンの兵士;T; I\"\n"
"utf-8;TI\"子供;T; I\"\n"
"utf-8;TI\"男性;T; I\"\n"
"utf-8;TI\"アヤネ;T; I\"\n"
"utf-8;TI\"レイラ;T; I\"\n"
"utf-8;TI\"リコレ;T; I\"\n"
"utf-8;TI\"ニコル;T; I\"\n"
"utf-8;TI\"ラボへ;T; I\"\n"
"utf-8;TI\"レイラ外イベ;T; I\"\n"
"utf-8;TI\"リコレニコルモブ;T; I\"\n"
"utf-8;TI\" リコレ・ニコルイベ;T; I\"\n"
"utf-8;TI\"リコレ奥配置;T; I\"\n"
"utf-8;TI\"ニコル奥配置;T; I\"\n"
"utf-8;TI\"ミロ;T; I\"\n"
"utf-8;TI\"ミロイベモブ;T; I\"\n"
"utf-8;TI\"中流エリアへ;T; I\"\n"
"utf-8;TI\"中流帰還イベ;T; I\"\n"
"utf-8;To;;;6;[ I\"2ボクが勝手にやったことだし……;T; I\"\n"
"utf-8;TI\" ./data/img/faces/yull10.pis;Ti i ;0@+o;;;6;[ I\"/そういうわけにはいきません!;T; I\"\n"
"utf-8;TI\"./data/img/faces/074.pis;Ti i ;0@+o;;;7;[\n"
"ii ;8i i ;0@+o;;;9;[iA;0[\"I\"中流エリアへ;T; I\"\n"
"utf-8;TI\"民家1へ;T; I\"\n"
"utf-8;TI\"民家2へ;T; I\"\n"
"utf-8;TI\"民家3へ;T; I\"\n"
"utf-8;TI\"レイラの家へ;T; I\"\n"
"utf-8;TI\"民家4へ;T; I\"\n"
"utf-8;TI\"ミロの家へ;T; I\"\n"
"utf-8;TI\"アルフィーネ;T; I\"\n"
"utf-8;TI\"最後の約束;T; I\"\n"
"utf-8;TI\"門番;T; I\"\n"
"utf-8;TI\"ごろつき;T; I\"\n"
"utf-8;TI\"うなだれる男性;T; I\"\n"
"utf-8;TI\";ボロボロの服の、座り込む品のある女性;T; I\"\n"
"utf-8;TI\"働く男性;T; I\"\n"
"utf-8;TI\"エルジオンの兵士;T; I\"\n"
"utf-8;TI\"子供;T; I\"\n"
"utf-8;TI\"男性;T; I\"\n"
"utf-8;TI\"アヤネ;T; I\"\n"
"utf-8;TI\"レイラ;T; I\"\n"
"utf-8;TI\"リコレ;T; I\"\n"
"utf-8;TI\"ニコル;T; I\"\n"
"utf-8;TI\"ラボへ;T; I\"\n"
"utf-8;TI\"レイラ外イベ;T; I\"\n"
"utf-8;TI\"リコレニコルモブ;T; I\"\n"
"utf-8;TI\" リコレ・ニコルイベ;T; I\"\n"
"utf-8;TI\"リコレ奥配置;T; I\"\n"
"utf-8;TI\"ニコル奥配置;T; I\"\n"
"utf-8;TI\"ミロ;T; I\"\n"
"utf-8;TI\"ミロイベモブ;T; I\"\n"
"utf-8;To;;;6;[ I\"Zあっ……じゃあ、\n"
"ちょっとついてきてもらってもいいですか?;T; I\"\n"
"utf-8;TI\"./data/img/faces/074.pis;Ti i ;0@+o;;;6;[ I\"8お見せしたいものがあるんです……♡;T; I\"\n"
"utf-8;TI\"./data/img/faces/074.pis;Ti i ;0@+o;;;6;[ I\"えっ……――;T; I\"\n"
"utf-8;TI\" ./data/img/faces/yull09.pis;Ti i ;0@+o;;;3;[iiI\"ミロの小屋イベ;T; I\"\n"
"utf-8;T;0@+o;;;;[iᩂXiퟆ�ii#;0[$I\"中流エリアへ;T; I\"\n"
"utf-8;TI\"民家1へ;T; I\"\n"
"utf-8;TI\"民家2へ;T; I\"\n"
"utf-8;TI\"民家3へ;T; I\"\n"
"utf-8;TI\"レイラの家へ;T; I\"\n"
"utf-8;TI\"民家4へ;T; I\"\n"
"utf-8;TI\"ミロの家へ;T; I\"\n"
"utf-8;TI\"アルフィーネ;T; I\"\n"
"utf-8;TI\"最後の約束;T; I\"\n"
"utf-8;TI\"門番;T; I\"\n"
"utf-8;TI\"ごろつき;T; I\"\n"
"utf-8;TI\"うなだれる男性;T; I\"\n"
"utf-8;TI\";ボロボロの服の、座り込む品のある女性;T; I\"\n"
"utf-8;TI\"働く男性;T; I\"\n"
"utf-8;TI\"エルジオンの兵士;T; I\"\n"
"utf-8;TI\"子供;T; I\"\n"
"utf-8;TI\"男性;T; I\"\n"
"utf-8;TI\"アヤネ;T; I\"\n"
"utf-8;TI\"レイラ;T; I\"\n"
"utf-8;TI\"リコレ;T; I\"\n"
"utf-8;TI\"ニコル;T; I\"\n"
"utf-8;TI\"ラボへ;T; I\"\n"
"utf-8;TI\"レイラ外イベ;T; I\"\n"
"utf-8;TI\"リコレニコルモブ;T; I\"\n"
"utf-8;TI\" リコレ・ニコルイベ;T; I\"\n"
"utf-8;TI\"リコレ奥配置;T; I\"\n"
"utf-8;TI\"ニコル奥配置;T; I\"\n"
"utf-8;TI\"ミロ;T; I\"\n"
"utf-8;TI\"ミロイベモブ;T; I\"\n"
"utf-8;TI\"中流エリアへ;T; I\"\n"
"utf-8;TI\"中流帰還イベ;T; I\"\n"
"utf-8;T;i ;i ;i;i ;i ; i ;!i;\"i;#i ;$i ;%i ;&i ;'i ;(i ;)i ;*i ;+i;,I\"%./data/img/characters/074_nl.pis;T;-i ;.i ;i7;i7;i ;\"i ;i ;#i ; i ;$i ;1Fo;;i\n"
";\n"
"i®;@;[o;;i ;i ;i ;i ;i ;[\n"
"o;;;6;[ I\"]なんでも中流エリアには\n"
"すげぇ発明家が隠れ住んでるって噂だぜ;T; I\"\n"
"utf-8;TI\" ;Ti i ;0[\"I\"中流エリアへ;T; I\"\n"
"utf-8;TI\"民家1へ;T; I\"\n"
"utf-8;TI\"民家2へ;T; I\"\n"
"utf-8;TI\"民家3へ;T; I\"\n"
"utf-8;TI\"レイラの家へ;T; I\"\n"
"utf-8;TI\"民家4へ;T; I\"\n"
"utf-8;TI\"ミロの家へ;T; I\"\n"
"utf-8;TI\"アルフィーネ;T; I\"\n"
"utf-8;TI\"最後の約束;T; I\"\n"
"utf-8;TI\"門番;T; I\"\n"
"utf-8;TI\"ごろつき;T; I\"\n"
"utf-8;TI\"うなだれる男性;T; I\"\n"
"utf-8;TI\";ボロボロの服の、座り込む品のある女性;T; I\"\n"
"utf-8;TI\"働く男性;T; I\"\n"
"utf-8;TI\"エルジオンの兵士;T; I\"\n"
"utf-8;TI\"子供;T; I\"\n"
"utf-8;TI\"男性;T; I\"\n"
"utf-8;TI\"アヤネ;T; I\"\n"
"utf-8;TI\"レイラ;T; I\"\n"
"utf-8;TI\"リコレ;T; I\"\n"
"utf-8;TI\"ニコル;T; I\"\n"
"utf-8;TI\"ラボへ;T; I\"\n"
"utf-8;TI\"レイラ外イベ;T; I\"\n"
"utf-8;TI\"リコレニコルモブ;T; I\"\n"
"utf-8;TI\" リコレ・ニコルイベ;T; I\"\n"
"utf-8;TI\"リコレ奥配置;T; I\"\n"
"utf-8;TI\"ニコル奥配置;T; I\"\n"
"utf-8;TI\"ミロ;T; I\"\n"
"utf-8;TI\"ミロイベモブ;T; I\"\n"
"utf-8;To;;;6;[ I\"oそこから発明品でもかっぱらってきて\n"
"売りさばけば金になりそうなんだが……;T; I\"\n"
"utf-8;TI\" ;Ti i ;0@P-o;;;6;[ I\"r門の前にいやがる兵士のせいで\n"
"中流には行き来ができねえからどうにもならねぇ;T; I\"\n"
"utf-8;TI\" ;Ti i ;0@P-o;;;6;[ I\"Qなぁにいちゃん、\n"
"試しにオトリになっちゃくれねぇか?;T; I\"\n"
"utf-8;TI\" ;Ti i ;0@P-o;;;6;[ I\"えぇ……イヤだよ;T; I\"\n"
"utf-8;TI\" ./data/img/faces/yull10.pis;Ti i ;0@P-;i ;i ;i ;i ;i ; i ;!i;\"i ;#i ;$i ;%i ;&i ;'i ;(i ;)i ;*i ;+i;,I\"+./data/img/characters/mob_lower_02.pis;T;-i;.i ;i7;i7;i ;\"i ;i ;#i ; i ;$i ;1Fo;;iD;\n"
"iU;@;[o;;i;i;i;i ;i ;[6o;;;4;[i i#;0[$I\"中流エリアへ;T; I\"\n"
"utf-8;TI\"民家1へ;T; I\"\n"
"utf-8;TI\"民家2へ;T; I\"\n"
"utf-8;TI\"民家3へ;T; I\"\n"
"utf-8;TI\"レイラの家へ;T; I\"\n"
"utf-8;TI\"民家4へ;T; I\"\n"
"utf-8;TI\"ミロの家へ;T; I\"\n"
"utf-8;TI\"アルフィーネ;T; I\"\n"
"utf-8;TI\"最後の約束;T; I\"\n"
"utf-8;TI\"門番;T; I\"\n"
"utf-8;TI\"ごろつき;T; I\"\n"
"utf-8;TI\"うなだれる男性;T; I\"\n"
"utf-8;TI\";ボロボロの服の、座り込む品のある女性;T; I\"\n"
"utf-8;TI\"働く男性;T; I\"\n"
"utf-8;TI\"エルジオンの兵士;T; I\"\n"
"utf-8;TI\"子供;T; I\"\n"
"utf-8;TI\"男性;T; I\"\n"
"utf-8;TI\"アヤネ;T; I\"\n"
"utf-8;TI\"レイラ;T; I\"\n"
"utf-8;TI\"リコレ;T; I\"\n"
"utf-8;TI\"ニコル;T; I\"\n"
"utf-8;TI\"ラボへ;T; I\"\n"
"utf-8;TI\"レイラ外イベ;T; I\"\n"
"utf-8;TI\"リコレニコルモブ;T; I\"\n"
"utf-8;TI\" リコレ・ニコルイベ;T; I\"\n"
"utf-8;TI\"リコレ奥配置;T; I\"\n"
"utf-8;TI\"ニコル奥配置;T; I\"\n"
"utf-8;TI\"ミロ;T; I\"\n"
"utf-8;TI\"ミロイベモブ;T; I\"\n"
"utf-8;TI\"中流エリアへ;T; I\"\n"
"utf-8;TI\"noname;To;;;/;[i iTii i ii;0@¦-o;;;5;[i#;0@¦-o;;;6;[ I\"0――ちょっと、\n"
"なにしてんの?;T; I\"\n"
"utf-8;TI\" ./data/img/faces/aria02.pis;Ti i ;0@¦-o;;;6;[ I\"Q下流から上のエリアへは\n"
"通行できなくなってるはずよ?;T; I\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")