using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<[^>]*>|\w+)";
string input = @"anim(10, <-0.016, -0.006, 0.217>, <0.000, 0.000, 0.707, 0.707>, <0.016, 0.010, 0.012>);
texture(-1, -1, 80c4c40e-4e59-f6db-4a3f-e2a82d1ebcc0, <1,1,1>, <0,0,0>, 0)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}