const regex = /(<[^>]*>|\w+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<[^>]*>|\\w+)', 'g')
const str = `anim(10, <-0.016, -0.006, 0.217>, <0.000, 0.000, 0.707, 0.707>, <0.016, 0.010, 0.012>);
texture(-1, -1, 80c4c40e-4e59-f6db-4a3f-e2a82d1ebcc0, <1,1,1>, <0,0,0>, 0)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}