package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^0-9,]+`)
var str = `100,23 zł
29,23 $`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}