$re = '/[^0-9,]+/';
$str = '100,23 zł
29,23 $';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);