import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Micron_5300)?(_|HC_)?MTFDDA[KV](240|480|960|1T9|3T8|7T6)TD[ST]";
final String string = "Micron_5300_MTFDDAK1T9TDS\n"
+ "Micron_5300HC_MTFDDAK960TDS\n"
+ "MTFDDAK1T9TDT";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}