use strict;
my $str = 'Micron_5300_MTFDDAK1T9TDS
Micron_5300HC_MTFDDAK960TDS
MTFDDAK1T9TDT';
my $regex = qr/(Micron_5300)?(_|HC_)?MTFDDA[KV](240|480|960|1T9|3T8|7T6)TD[ST]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}