re = /(.*) (KEY) ([^0-9]*)(\d+)/
str = 'test 74488 hdhd2 768 788 KEY bla gjjjcrs 6448. gfudj778. 2 bla 77545 77890 7754'
# Print the match result
str.match(re) do |match|
puts match.to_s
end