#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Uptime\s+(?<Uptime>.+)"
Local $sString = "Instance Name : ABCDEFGH1" & @CRLF & _
"Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=ampxwdp1o.pharma.aventis.com)(PORT=12345)))" & @CRLF & _
"Alias ABCDEFGH1" & @CRLF & _
"Uptime 4 days 6 hr. 39 min. 25 sec" & @CRLF & _
"Listening Endpoints Summary..." & @CRLF & _
"(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=113.09.126.234)(PORT=12345)))" & @CRLF & _
"(DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(KEY=EXTPROC12345)))" & @CRLF & _
"The command completed successfully" & @CRLF & _
"Instance Name : ABCDEFGH1TEMP" & @CRLF & _
"Instance Name : ABCDEFGQ1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")