import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Uptime\\s+(?<Uptime>.+)";
final String string = "Instance Name : ABCDEFGH1\n"
+ "Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=ampxwdp1o.pharma.aventis.com)(PORT=12345)))\n"
+ "Alias ABCDEFGH1\n"
+ "Uptime 4 days 6 hr. 39 min. 25 sec\n"
+ "Listening Endpoints Summary...\n"
+ "(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=113.09.126.234)(PORT=12345)))\n"
+ "(DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(KEY=EXTPROC12345)))\n"
+ "The command completed successfully\n"
+ "Instance Name : ABCDEFGH1TEMP\n"
+ "Instance Name : ABCDEFGQ1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}