const regex = /tags:\s*|\s*$|( ) +/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('tags:\\s*|\\s*$|( ) +', 'gm')
const str = `JavaScript, Markdown, Web , programming skill `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);