re = /tags:\s*|\s*$|( ) +/m
str = 'JavaScript, Markdown, Web , programming skill '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result