import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<p>(<i>|<strong>)*<img.*<\\/p>";
final String string = "<p><img class=\"mceItem_breakpoint\" src=\"></p>\n"
+ "<h4>Platzteller</h4>\n"
+ "<p>Der Platzteller, auf dem Vorspeisen- und Suppenteller rechts daneben</p>\n"
+ "<p><i><img class=\"mceItem_breakpoint\" src=\"\" /></i></p>\n"
+ "<p><strong><img class=\"mceItem_breakpoint\" src=\"\"></strong></p>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}