import re
regex = re.compile(r"<p>(<i>|<strong>)*<img.*<\/p>")
test_str = ("<p><img class=\"mceItem_breakpoint\" src=\"></p>\n"
"<h4>Platzteller</h4>\n"
"<p>Der Platzteller, auf dem Vorspeisen- und Suppenteller rechts daneben</p>\n"
"<p><i><img class=\"mceItem_breakpoint\" src=\"\" /></i></p>\n"
"<p><strong><img class=\"mceItem_breakpoint\" src=\"\"></strong></p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")