#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([:\[,])(?![+-]?\d+\.?\d*)(?!false|true)(?!".*?")([^\{\[\r\n]*?)([,\]\}])"
Local $sString = ""bla":12.0," & @CRLF & _
""bla":+12.0," & @CRLF & _
""bla":-12.0," & @CRLF & _
""bla":+12," & @CRLF & _
""bla":false," & @CRLF & _
""bla":true," & @CRLF & _
""bla":+12.0.0," & @CRLF & _
""bla":"string"," & @CRLF & _
""bla":path," & @CRLF & _
""bla":pathWith0.2," & @CRLF & _
""bla":," & @CRLF & _
""bla":{"inner":false,"bli":"s","blu":path}," & @CRLF & _
""bla":[path1,path2,path3}," & @CRLF & _
""
Local $sSubst = "$1"$2"$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)