using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([:\[,])(?![+-]?\d+\.?\d*)(?!false|true)(?!"".*?"")([^\{\[\r\n]*?)([,\]\}])";
string substitution = @"$1""$2""$3";
string input = @"""bla"":12.0,
""bla"":+12.0,
""bla"":-12.0,
""bla"":+12,
""bla"":false,
""bla"":true,
""bla"":+12.0.0,
""bla"":""string"",
""bla"":path,
""bla"":pathWith0.2,
""bla"":,
""bla"":{""inner"":false,""bli"":""s"",""blu"":path},
""bla"":[path1,path2,path3},
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}