package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\s*function\s+([a-zA-Z$_][a-zA-Z\d$_]*)\s*\(`)
var str = `
function
$$
(z) {
if (z == true) {
console.log ("Something says Z is true");
}
}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}