import Foundation
let pattern = #"^\s*function\s+([a-zA-Z$_][a-zA-Z\d$_]*)\s*\("#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
function
$$
(z) {
if (z == true) {
console.log ("Something says Z is true");
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}