#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*\.)(exe|mp3|mp4)$"
Local $sString = "anything_you_wish_here.exe" & @CRLF & _
"anything_you_wish_here.mp4" & @CRLF & _
"anything_you_wish_here.mp3" & @CRLF & _
"anything_you_wish_here.jpg" & @CRLF & _
"anything_you_wish_here.png"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")