re = /^(.*\.)(exe|mp3|mp4)$/m
str = 'anything_you_wish_here.exe
anything_you_wish_here.mp4
anything_you_wish_here.mp3
anything_you_wish_here.jpg
anything_you_wish_here.png'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end